当前位置:文档之家› ospf+BGP实验配置

ospf+BGP实验配置

[r1]dis cur
Now create configuration...
Current configuration
!
version 1.44
local-user hhh service-type ftp password simple 123
router id 192.168.20.1
firewall enable
sysname r1
ftp-server enable
!
interface Ethernet0
ip address 192.168.100.1 255.255.255.0
ospf enable area 0.0.0.0
!
interface Serial0
clock DTECLK1
link-protocol ppp
ip address 192.168.20.1 255.255.255.0
ospf enable area 0.0.0.0
!
interface Serial1
link-protocol ppp
!
interface Serial2
flow-control none
async mode protocol
link-protocol ppp
!
quit
ospf enable
!
quit
!

return

[r1]


.......................



[r2]dis cur
Now create configuration...
Current configuration
!
version 1.44
router id 192.168.30.1
firewall enable
sysname r2
!
interface Ethernet0
ip address 192.168.30.1 255.255.255.0
ospf enable area 0.0.0.1
!
interface Serial0
link-protocol ppp
ip address 192.168.20.2 255.255.255.0
ospf enable area 0.0.0.0
!
interface Serial1
link-protocol ppp
!
interface Serial2
flow-control none
async mode protocol
link-protocol ppp
!
quit
ospf enable
!
quit
!

return
................................


[r3]dis cur
Now create configuration...
Current configuration
!
version 1.44
router id 192.168.40.1
firewall enable
sysname r3
!
interface Ethernet0
ip address 192.168.30.2 255.255.255.0
ospf enable area 0.0.0.1
!
interface Serial0
link-protocol ppp
!
interface Serial1
undo detect DSR-DTR
link-protocol fr
ip address 192.168.40.1 255.255.255.0
ospf enable area 0.0.0.1
ospf peer 192.168.40.2
!
interface Serial2
flow-control none
async mode protocol
link-protocol ppp
!
quit
ospf enable
!
quit
!

return

[r3]...




................


[[r4]dis cur
Now create configuration...
Current configuration
!
version 1.44
router id 192.168.40.1
firewall enable
sysname r4
!
interface Ethernet0
ip address 192.168.50.1 255.255.255.0
ospf enable area 0.0.0.1
!
interface Serial0
link-protocol fr
fr map ip 192.168.40.1 dlci 200
ip address 192.168.40.2 255.255.255.0
ospf enable area 0.0.0.1
ospf peer 192.168.40.1
!
interface Serial1
link-protocol ppp
!
interface Serial2
flow-control none
async mode protocol
link-protocol ppp
!
quit
ospf enable
!
quit
!

return

[r4]


...........................

[r5]dis cur
Now create configuration...
Current configuration
!
version 1.44
firewall enable
sysname r5
fr switching
!
interface Ethernet0

!
interface Serial0
clock DTECLK1
link-protocol fr
fr interface-type DCE
fr dlci-switch pvc 200 interface Serial 1 dlci 100
!
interface Serial1
clock DTECLK1
link-protocol fr
fr interface-type DCE
fr dlci-switch pvc 100 interface Serial 0 dlci 200
!
interface Serial2
flow-control none
async mode protocol
link-protocol ppp
!

return

[r5]



..........................



r6]dis cur
Now create configuration...
Current configuration
!
version 1.44
router id 192.168.50.2
firewall enable
sysname r6
!
interface Ethernet0
ip address 192.168.50.2 255.255.255.0
ospf enable area 0.0.0.1
!
interface Serial0
clock DTECLK1
undo detect DSR-DTR
link-protocol ppp
ip address 192.168.60.1 255.255.255.0
!
interface Serial1
link-protocol ppp
!
interface Serial2
flow-control none
async mode protocol
link-protocol ppp
!
quit
ospf enable
import-route static type 2 cost 2 tag 1
import-route direct type 2 cost 2 tag 1
!
quit
!
quit
ip route-static 0.0.0.0 0.0.0.0 192.168.50.1 preference 60
ip route-static 192.168.70.0 255.255.255.0 192.168.60.2 preference 60
!

return

[r6]


.......................



[r7]dis cur
Now create configuration...
Current configuration
!
version 1.44
firewall enable
sysname r7
!
interface Ethernet0
ip address 192.168.70.1 255.255.255.0
!
interface Serial0
link-protocol ppp
ip address 192.168.60.2 255.255.255.0
!
interface Serial1
link-protocol ppp
!
interface Serial2
flow-control none
async mode protocol
link-protocol ppp
!
quit
ip route-static 0.0.0.0 0.0.0.0 192.168.60.1 preference 60
!

return

[r7]

...........................


[r8]dis cur
Now create configuration...
Current configuration
!
version 1.44
firewall enable
sysname r8
!
interface Ethernet0
ip address 192.168.70.2 255.255.255.0
!
interface Serial0
link-protocol ppp
!
interface Serial1
link-protocol ppp
!
interface Serial2
flow-control none
async mode protocol
link-protocol ppp
!
quit
ip route-static 0.0.0.0 0.0.0.0 192.168.70.1 preference 60
ip route-static 192.168.60.0 255.255.255.0 192.168.70.1 preference 60
!

return

[r8]

......................


cisco#show run
Building configuration...

Current configuration : 1057 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cisco
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
no ip domain-lo

okup
!
no ip dhcp-client network-discovery
!
!
!
!
interface Loopback1
ip address 172.16.12.1 255.255.255.0
!
interface Loopback2
ip address 172.16.13.1 255.255.255.0
!
interface Loopback3
ip address 172.16.14.1 255.255.255.0
!
interface Loopback4
ip address 172.16.15.1 255.255.255.0
!
interface Ethernet0
ip address 192.168.10.2 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
router bgp 200
no synchronization
bgp log-neighbor-changes
aggregate-address 172.16.12.0 255.255.252.0 summary-only
redistribute connected
neighbor 192.168.10.1 remote-as 100
!
ip kerberos source-interface any
ip classless
no ip http server
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
transport input none
line aux 0
line vty 0 4
login
!
end

cisco#


................................[3526]dis cur
#
sysname 3526
#
radius scheme system
server-type huawei
primary authentication 127.0.0.1 1645
primary accounting 127.0.0.1 1646
user-name-format without-domain

domain system
radius-scheme system
access-limit disable
state active
idle-cut disable
self-service-url disable
messenger time disable

domain default enable system
#
local-server nas-ip 127.0.0.1 key huawei
#
router id 192.168.100.2
#
vlan 1
#
vlan 24
#
interface Vlan-interface1
ip address 192.168.100.2 255.255.255.0
#
interface Vlan-interface24
ip address 192.168.10.1 255.255.255.0
#
interface Aux0/0
#
interface Ethernet0/1
#
interface Ethernet0/2
#
interface Ethernet0/3
#
interface Ethernet0/4
#
interface Ethernet0/5
#
interface Ethernet0/6
#
interface Ethernet0/7
#
interface Ethernet0/8
#
interface Ethernet0/9
#
interface Ethernet0/10
#
interface Ethernet0/11
#
interface Ethernet0/12
#
interface Ethernet0/13
#
interface Ethernet0/14
#
interface Ethernet0/15
#
interface Ethernet0/16
#
interface Ethernet0/17
#
interface Ethernet0/18
#
interface Ethernet0/19
#
interface Ethernet0/20
#
interface Ethernet0/21
#
interface Ethernet0/22
#
interface Ethernet0/23
#
interface Ethernet0/24
port access vlan 24
#
interface GigabitEthernet2/1
#
interface NULL0
#
interface LoopBack1
ip address 1.1.1.1 255.255.255.0
#
interface LoopBack2
ip address 2.2.2.2 255.255.255.0
#
interface LoopBack3
ip address 3.3.3.3 255.255.255.0
#
interface LoopBack4
ip address 4.4.4.4 255.255.255.0
#
interface LoopBack5
ip address 5.5.5.5 255.255.255.0
#
bgp 100
network 192.168.70.0
network 192.168.60.0
network 192.168.50.0
network 192.168.40.0
network 192.168.30.0
network 192.168.20.0
network 192.168.100.0
network 192.168.10.0
import-route ospf
undo synchronization
peer 192.168.10.2 as-number 200
#
ospf
import-route direct cost 2
area 0.0.0.0
network 1.1.1.0 0.0.0.

255
network 2.2.2.0 0.0.0.255
network 3.3.3.0 0.0.0.255
network 4.4.4.0 0.0.0.255
network 5.5.5.0 0.0.0.255
network 192.168.100.0 0.0.0.255
#
user-interface aux 0
user-interface vty 0 4
#
return
[3526]

相关主题
文本预览
相关文档 最新文档