当前位置:文档之家› 锐捷常用命令及个例

锐捷常用命令及个例

锐捷常用命令及个例
锐捷常用命令及个例

1. 计算机命令:

PCA login: root ;使用root用户password: linux ;口令是linux

# shutdown -h now ;同init 0 关机

# logout

# login

# ifconfig ;显示IP地址

# ifconfig eth0 netmask ;设置IP地址

# ifconfig eht0 netmask down ;删除IP地址

# route add 0.0.0.0 gw

# route del 0.0.0.0 gw

# route add default gw ;设置网关

# route del default gw ;删除网关

# route ;显示网关

# ping

# telnet

2. 交换机支持的命令:

交换机基本状态:

switch: ;交换机的ROM状态rommon> ;路由器的ROM状态hostname> ;用户模式hostname# ;特权模式

hostname(config)# ;全局配置模式hostname(config-if)# ;接口状态

交换机口令设置:

switch>enable ;进入特权模式

switch#config terminal ;进入全局配置模式switch(config)#hostname ;设置交换机的主机名switch(config)#enable secret xxx ;设置特权加密口令

switch(config)#enable password xxa ;设置特权非密口令

switch(config)#line console 0 ;进入控制台口

switch(config-line)#line vty 0 4 ;进入虚拟终端

switch(config-line)#login ;允许登录

switch(config-line)#password xx ;设置登录口令xx

switch#exit ;返回命令

交换机VLAN设置:

switch#vlan database ;进入VLAN设置switch(vlan)#vlan 2 ;建VLAN 2

switch(vlan)#no vlan 2 ;删vlan 2

switch(config)#int f0/1 ;进入端口1

switch(config-if)#switchport access vlan 2 ;当前端口加入vlan 2

switch(config-if)#switchport mode trunk ;设置为干线

switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的vlan

switch(config-if)#switchport trunk encap dot1q ;设置vlan 中继

switch(config)#vtp domain ;设置发vtp域名switch(config)#vtp password ;设置发vtp密码switch(config)#vtp mode server ;设置发vtp模式switch(config)#vtp mode client ;设置发vtp模式

交换机设置IP地址:

switch(config)#interface vlan 1 ;进入vlan 1

switch(config-if)#ip address ;设置IP地址

switch(config)#ip default-gateway ;设置默认网关

switch#dir flash: ;查看闪存

交换机显示命令:

switch#write ;保存配置信息switch#show vtp ;查看vtp配置信息switch#show run ;查看当前配置信息switch#show vlan ;查看vlan配置信息switch#show interface ;查看端口信息switch#show int f0/0 ;查看指定端口信息

3. 路由器支持的命令:

路由器显示命令:

router#show run ;显示配置信息router#show interface ;显示接口信息router#show ip route ;显示路由信息router#show cdp nei ;显示邻居信息router#reload ;重新起动

路由器口令设置:

router>enable ;进入特权模式router#config terminal ;进入全局配置模式router(config)#hostname ;设置交换机的主机名router(config)#enable secret xxx ;设置特权加密口令router(config)#enable password xxb ;设置特权非密口令router(config)#line console 0 ;进入控制台口

router(config-line)#line vty 0 4 ;进入虚拟终端

router(config-line)#login ;要求口令验证

router(config-line)#password xx ;设置登录口令xx router(config)#(Ctrl+z) ;返回特权模式router#exit ;返回命令

路由器配置:

router(config)#int s0/0 ;进入Serail接口

router(config-if)#no shutdown ;激活当前接口

router(config-if)#clock rate 64000 ;设置同步时钟

router(config-if)#ip address ;设置IP地址

router(config-if)#ip address second ;设置第二个IP

router(config-if)#int f0/0.1 ;进入子接口

router(config-subif.1)#ip address ;设置子接口IP

router(config-subif.1)#encapsulation dot1q ;绑定vlan中继协议

router(config)#config-register 0x2142 ;跳过配置文件

router(config)#config-register 0x2102 ;正常使用配置文件

router#reload ;重新引导

路由器文件操作:

router#copy running-config startup-config ;保存配置

router#copy running-config tftp ;保存配置到tftp

router#copy startup-config tftp ;开机配置存到tftp

router#copy tftp flash: ;下传文件到flash

router#copy tftp startup-config ;下载配置文件

ROM状态:

Ctrl+Break ;进入ROM监控状态rommon>confreg 0x2142 ;跳过配置文件rommon>confreg 0x2102 ;恢复配置文件rommon>reset ;重新引导

rommon>copy xmodem: flash: ;从console传输文件

rommon>IP_ADDRESS=10.65.1.2 ;设置路由器IP rommon>IP_SUBNET_MASK=255.255.0.0 ;设置路由器掩码rommon>TFTP_SERVER=10.65.1.1 ;指定TFTP服务器IP rommon>TFTP_FILE=c2600.bin ;指定下载的文件rommon>tftpdnld ;从tftp下载rommon>dir flash: ;查看闪存内容rommon>boot ;引导IOS

静态路由:

ip route ;命令格式

router(config)#ip route 2.0.0.0 255.0.0.0 1.1.1.2 ;静态路由举例

router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2 ;默认路由举例

动态路由:

router(config)#ip routing ;启动路由转发

router(config)#router rip ;启动RIP路由协议。

router(config-router)#network ;设置发布路由

router(config-router)#negihbor ;点对点帧中继用。

帧中继命令:

router(config)#frame-relay switching ;使能帧中继交换router(config-s0)#encapsulation frame-relay ;使能帧中继

router(config-s0)#fram-relay lmi-type cisco ;设置管理类型

router(config-s0)#frame-relay intf-type DCE ;设置为DCE

router(config-s0)#frame-relay dlci 16 ;

router(config-s0)#frame-relay local-dlci 20 ;设置虚电路号

router(config-s0)#frame-relay interface-dlci 16 ;

router(config)#log-adjacency-changes ;记录邻接变化router(config)#int s0/0.1 point-to-point ;设置子接口点对点router#show frame pvc ;显示永久虚电路router#show frame map ;显示映射

基本访问控制列表:

router(config)#access-list permit|deny router(config)#interface ;default:deny any router(config-if)#ip access-group in|out ;default:out

例1:

router(config)#access-list 1 deny host 10.65.1.1

router(config)#access-list 1 permit any

router(config)#int f0/0

router(config-if)#ip access-group 4 in

例2:

router(config)#access-list 4 permit 10.8.1.1

router(config)#access-list 4 deny 10.8.1.0 0.0.0.255

router(config)#access-list 4 permit 10.8.0.0 0.0.255.255

router(config)#access-list 4 deny 10.0.0.0 0.255.255.255

router(config)#access-list 4 permit any

router(config)#int f0/1

router(config-if)#ip access-group 4 in

扩展访问控制列表:

access-list permit|deny icmp [type] access-list permit|deny tcp [port]

例1:

router(config)#access-list 101 deny icmp any 10.64.0.2 0.0.0.0 echo

router(config)#access-list 101 permit ip any any

router(config)#int s0/0

router(config-if)#ip access-group 101 in

例2:

router(config)#access-list 102 deny tcp any 10.65.0.2 0.0.0.0 eq 80

router(config)#access-list 102 permit ip any any

router(config)#interface s0/1

router(config-if)#ip access-group 102 out

删除访问控制例表:

router(config)#no access-list 102

router(config-if)#no ip access-group 101 in

路由器的nat配置

Router(config-if)#ip nat inside ;当前接口指定为内部接口Router(config-if)#ip nat outside ;当前接口指定为外部接口Router(config)#ip nat inside source static [p] <私有IP><公网IP> [port] Router(config)#ip nat inside source static 10.65.1.2 60.1.1.1

Router(config)#ip nat inside source static tcp 10.65.1.3 80 60.1.1.1 80 Router(config)#ip nat pool p1 60.1.1.1 60.1.1.20 255.255.255.0

Router(config)#ip nat inside source list 1 pool p1

Router(config)#ip nat inside destination list 2 pool p2

Router(config)#ip nat inside source list 2 interface s0/0 overload

Router(config)#ip nat pool p2 10.65.1.2 10.65.1.4 255.255.255.0 type rotary Router#show ip nat translation

rotary 参数是轮流的意思,地址池中的IP轮流与NAT分配的地址匹配。overload参数用于PAT 将内部IP映射到一个公网IP不同的端口上。

外部网关协议配置

routerA(config)#router bgp 100

routerA(config-router)#network 19.0.0.0

routerA(config-router)#neighbor 8.1.1.2 remote-as 200

配置PPP验证:

RouterA(config)#username password

RouterA(config)#int s0

RouterA(config-if)#ppp authentication {chap|pap}

4.PIX防火墙命令

Pix525(config)#nameif ethernet0 outside security0 ;命名接口和级别Pix525(config)#interface ethernet0 auto ;设置接口方式Pix525(config)#interface ethernet1 100full ;设置接口方式Pix525(config)#interface ethernet1 100full shutdown

Pix525(config)#ip address inside 192.168.0.1 255.255.255.0

Pix525(config)#ip address outside 133.0.0.1 255.255.255.252

Pix525(config)#global (if_name) natid ip-ip ;定义公网IP区间Pix525(config)#global (outside) 1 7.0.0.1-7.0.0.15 ;例句

Pix525(config)#global (outside) 1 133.0.0.1 ;例句

Pix525(config)#no global (outside) 1 133.0.0.1 ;去掉设置

Pix525(config)#nat (if_name) nat_id local_ip [netmark]

Pix525(config)#nat (inside) 1 0 0

内网所有主机(0代表0.0.0.0)可以访问global 1指定的外网。

Pix525(config)#nat (inside) 1 172.16.5.0 255.255.0.0

内网172.16.5.0/16网段的主机可以访问global 1指定的外网。

Pix525(config)#route if_name 0 0 gateway_ip [metric] ;命令格式Pix525(config)#route outside 0 0 133.0.0.1 1 ;例句

Pix525(config)#route inside 10.1.0.0 255.255.0.0 10.8.0.1 1 ;例句

Pix525(config)#static (inside,outside) 133.0.0.1 192.168.0.8

表示内部ip地址192.168.0.8,访问外部时被翻译成133.0.0.1全局地址。

Pix525(config)#static (dmz,outside) 133.0.0.1 172.16.0.8

中间区域ip地址172.16.0.8,访问外部时被翻译成133.0.0.1全局地址。

锐捷交换机常用操作命令

一、交换机配置模式介绍 (2) 二、交换机基本配置 (2) 2.1 接口介质类型配置 (3) 2.2 接口速度/双工配置 (3) 2.3 VLAN配置 (4) 2.4 端口镜像 (5) 2.5 端口聚合 (6) 2.6 交换机堆叠 (6) 2.7 ACL配置 (7) 2.8 端口安全 (8) 2.9 交换机防攻击配置 (10) 2.10 DHCP配置 (13) 2.11 三层交换机配置 (14) 三、交换机常用查看命令 (16)

一、交换机配置模式介绍 交换机配置模式主要有: 用户模式:此模式只可以简单的查看一些交换机的配置和一些简单的修改。 Switch> 特权模式:此模式可以查看一些交换机的配置,后面讲述的很多show命令便是在此模式下进行的,还可以对一些简单的设置配置,例如时间。 Switch> enable //在用户模式下输入enable将进入配置模式 Switch# 全局配置模式:此模式下可以进行对交换机的配置,例如:命名、配置密码、设路由等。Switch#configure erminal //特权模式下可以通过config terminal 命令进入配置模式Switch(config)# 端口配置模式:此模式下对端口进行配置,如配置端口ip等。 Switch(config)#interface gigabitEthernet 1/1 //配置模式下输入interface gigabitEthernet 1/1进入到端口g 1/1接口模式。 二、交换机基本配置 交换机命名:在项目实施的时候,建议为处于不同位置的交换机命名,便于记忆,可提高后期管理效率。 switch(config)#hostname ruijie //ruijie为该交换机的名字 交换机配置管理密码:配置密码可以提高交换机的安全性,另外,telnet登录交换机的时候,必须要求有telnet管理密码。 switch (config)#enable secret level 1 0 rg //配置telnet管理密码为rg,其中1表示telnet密码,0表示密码不加密 switch (config)#enable secret level 15 0 rg //配置特权模式下的管理密码rg,其中15表示为特权密码 交换机配置管理IP switch (config)#interface vlan 1 //假设管理VLAN为VLAN 1 switch (config-if)#ip address 192.168.1.1 255.255.255.0 //给管理VLAN配置管理IP地址 switch (config-if)#no shutdown //激活管理IP,养成习惯,无论配置什么设备,都使用一下这个命令

锐捷基本命令大全

>Enable 进入特权模式 #Exit 返回上一级操作模式 #End 返回到特权模式 #write memory 或copy running-config startup-config 保存配置文件 #del flash:config.text 删除配置文件(交换机及1700系列路由器) #erase startup-config 删除配置文件(2500系列路由器) #del flash:vlan.dat 删除Vlan配置信息(交换机) #Configure terminal 进入全局配置模式 (config)# hostname switchA 配置设备名称为switchA (config)#banner motd & 配置每日提示信息&为终止符 (config)#enable secret level 1 0 star 配置远程登陆密码为star (config)#enable secret level 15 0 star 配置特权密码为star Level 1为普通用户级别,可选为1~15,15为最高权限级别;0表示密码不加密 (config)#enable services web-server 开启交换机WEB管理功能 Services 可选以下:web-server(WEB管理)、telnet-server(远程登陆)等 查看信息 #show running-config 查看当前生效的配置信息 #show interface fastethernet 0/3 查看F0/3端口信息 #show interface serial 1/2 查看S1/2端口信息 #show interface 查看所有端口信息 #show ip interface brief 以简洁方式汇总查看所有端口信息 #show ip interface 查看所有端口信息 #show version 查看版本信息 #show mac-address-table 查看交换机当前MAC地址表信息 #show running-config 查看当前生效的配置信息 #show vlan 查看所有VLAN信息 #show vlan id 10 查看某一VLAN (如VLAN10)的信息 #show interface fastethernet 0/1 switchport 查看某一端口模式(如F 0/1) #show aggregateport 1 summary 查看聚合端口AG1的信息 #show spanning-tree 查看生成树配置信息 #show spanning-tree interface fastethernet 0/1 查看该端口的生成树状态 #show port-security 查看交换机的端口安全配置信息 #show port-security address 查看地址安全绑定配置信息 #show ip access-lists listname 查看名为listname的列表的配置信息 #show access-lists 端口的基本配置 (config)#Interface fastethernet 0/3 进入F0/3的端口配置模式 (config)#interface range fa 0/1-2,0/5,0/7-9 进入F0/1、F0/2、F0/5、F0/7、F0/8、F0/9的端口配置模式 (config-if)#speed 10 配置端口速率为10M,可选10,100,auto (config-if)#duplex full 配置端口为全双工模式,可选full(全双工),half(半双式),auto(自适应) (config-if)#no shutdown 开启该端口 (config-if)#switchport access vlan 10 将该端口划入VLAN10中,用于VLAN

关于锐捷路由器配置命令

关于锐捷路由器配置命令,这些命令可能用的都不是很多,但是对于网络安全和性能来说很重要。 1. #Exit返回上一级操作模式 2. #del flash:config.text删除配置文件(交换机及1700系列路由器) 3. #erase startup-config删除配置文件(2500系列路由器) 4. #write memory 或copy running-config startup-config 保存配置 5. #Configure terminal 进入全局配置模式 6. (config)# hostname routerA配置设备名称为routerA 7.(config)#banner motd &配置每日提示信息&为终止符 8. (config)# enable secret star或者:enable password star 9.设置路由器的特权模式密码为star;secret 指密码以非明文显示, password指密码以明文显示 10.锐捷路由器配置命令之查看信息 11. #show running-config 查看当前生效的配置信息 12. #show interface fastethernet 0/3查看F0/3端口信息 13. #show interface serial 1/2 查看S1/2端口信息 14. #show ip interface brief 查看端口信息 15. #show version查看版本信息 16.#show running-config 查看当前生效的配置信息 17. #show controllers serial 1/2 查看该端口信息 , 用于R2501 18. #show ip route 查看路由表信息 19. #show access-lists 1查看标准访问控制列表1的配置信息 20.锐捷路由器配置命令之远程登陆(telnet) 21. (config)# line vty 0 4 进入线路0~4的配置模式, 4为连续线路最后一位的编号,线路为0~4 22. (conifg-line)#login 23. (config-line)#password star配置远程登陆密码为star 24. (config-line)#end返回上层 25. 锐捷路由器配置命令之端口的基本配置 26. (config)#Interface fastethernet 0/3 进入F0/3的端口配置模式 27. (config)#interface range fa 0/1-2进入F01至F0/2的端口配置模式 28. (config-if)#speed 10 配置端口速率为10M,可选10,100,auto 29. (config-if)#duplex full配置端口为全双工模式, 可选full(全双工),half(半双式),auto(自适应) 30. (config-if)#no shutdown 开启该端口 31. (config)# interface serial 1/2 进入端口S1/2的配置模式 32. (config-if)# ip address 1.1.1.1 255.255.255.0 配置端口IP及掩码 33.(config-if)# clock rate 64000 配置时钟频率(单位为K , 仅用于DCE端) 34.(config-if)# bandwidth 512 配置端口带宽速率为512KB(单位为KB) 35. (config-if)# no shutdown 开启该端口 36. (config-if)#encapsulation PPP 定义封装类型为PPP,可选项: 37. Frame-relay 帧中继 38. Hdlc 高级数据链路控制协议 39. lapb X.25的二层协议

锐捷交换机配置手册簿完整

锐捷S3550配置手册 第一部分:交换机概述 一:交换机的几种配置方法 本部分包括以下内容: 控制台 远程登录 其它配置方法 本部分内容适用于交换机、路由器等网络设备。 控制台 用一台计算机作为控制台和网络设备相连,通过计算机对网络设备进行配置。 1、硬件连接: 把Console线一端连接在计算机的串行口上,另一端连接在网络设备的Console口上。Console线在购置网络设备时会提供,它是一条反转线,你也可以自己用双绞线进行制作。

按照上面的线序制作一根双绞线,一端通过一个转接头连接在计算机的串行口上,另一端连 接在网络设备的Console口上。 注意:不要把反转线连接在网络设备的其他接口上,这有可能导致设备损坏。 2、软件安装: 在计算机上需要安装一个终端仿真软件来登录网络设备。通常我们使用Windows自带的“超级终端”。超级终端的安装方法: 开始| 程序| 附件| 通信| 超级终端。 按照提示的步骤进行安装,其中连接的接口应选择“COM1”,端口的速率应选择“9600”,数据流控制应选择“无”,其它都使用默认值。

登录后,就可以对网络设备进行配置了。 说明:超级终端只需安装一次,下次再使用时可从“开始| 程序| 附件| 通信| 超级终端”中找到上次安装的超级终端,直接使用即可。 远程登录 通过一台连接在网络中的计算机,用Telnet命令登录网络设备进行配置。 远程登录条件: 1、网络设备已经配置了IP地址、远程登录密码和特权密码。 2、网络设备已经连入网络工作。

3、计算机也连入网络,并且可以和网络设备通信。 说明:远程登录的计算机不是连接在网络设备Console口上的计算机,而是网络中任一台计算机。 远程登录方法: 在计算机的命令行中,输入命令“telnet 网络设备IP地址”,输入登录密码就可以进入网 络设备的命令配置模式。 说明:远程登录方式不能用来配置新设备,新设备应该用控制台配置IP地址等参数,以后才能使用远程登录进行配置。 其它配置方法 除了控制台和远程登录之外,还有其它一些配置方法配置网络设备。 1、TFTP服务器: TFTP服务器是网络中的一台计算机,你可以把网络设备的配置文件等信息备份到TFTP服务器之中,也可以把备份的文件传回到网络设备中。 由于设备的配置文件是文本文件,所以,你可以用文本编辑软件打开进行修改,再把修改后 的配置文件传回网络设备,这样就可以实现配置功能。你也可以用TFTP服务器把一个已经做好的配置文件上传到一台同型号的设备中实现对它的配置。

锐捷路由器命令大全

锐捷路由器命令大全 2007-09-07 21:08 出现攻击时掉线时请用console链接路由,保存好如下命令的相关内容,用以分析: 1、show ver (版本信息) 2、show run (配置信息) 3、show arp (arp信息) 4、show interface (端口信息) 5、show ip nat trans (nat信息) 6、show ip nat stat 7、show ip nat statistics per-user (只要第1屏的信息) 8、show ip cache (只要第1屏的信息) 9、show ip nat statistics suspicious-pc 发送免费arp: lh#conf t Enter configuration commands, one per line. End with CNTL/Z. lh(config)#int f 0/0(内网) lh(config)#arp gr int 1 lh(config)#int f 1/0(外网) lh(config)#arp gr int 1 lh(config)#end lh#wr端口映射: lh#conf t Enter configuration commands, one per line. End with CNTL/Z. lh(config)#ip nat source static tcp 192.168.3.99ip 80 219.128.102.110 80 permit-inside lh(config)#end lh#wr限制内网某机器不限速(192.168.2.80): lh#conf t Enter configuration commands, one per line. End with CNTL/Z. lh(config)#ip nat translation rate-limit iprange 192.168.2.2 192.168.2.79 inbound 500 outbound 1000 lh(config)#ip nat translation rate-limit iprange 192.168.2.81 192.168.3.253 inbound 500 outbound 1000 lh(config)#end lh#wr限制内网PC的链接线程数同限速: lh#conf t Enter configuration commands, one per line. End with CNTL/Z. lh(config)#ip nat translation per-user 0.0.0.0 250 lh(config)#ip nat translation rate-limit default inbound 500 outbound 1000 lh(config)#end lh#wr禁止公网访问IP lh#conf t Enter configuration commands, one per line. End with CNTL/Z.

配置策略路由命令 锐捷

33.1配置相关命令 33.1.1ip policy route-map 要在一个接口启用策略路由,请使用接口配置命令ip policy route-map。 该命令的no形式关闭策略路由的应用。 ip policy route-map route-map no ip policy route-map 【参数说明】 【缺省情况】 缺省关闭策略路由。 【命令模式】 接口配置模式。 【使用指南】 策略路由必须在指定的接口上应用,该接口只对接收到的数据包进行策略 路由,该接口发送的数据包路由将正常按照路由表进行转发。 应用策略路由,必须要指定策略路由使用的路由图,并且要创建路由图。 一个路由图由很多条策略组成,每个策略都定义了1个或多个的匹配规 则和对应操作。一个接口应用策略路由后,将对该接口接收到的所有包进 行检查,不符合路由图任何策略的数据包将按照通常的路由转发进行处理, 符合路由图中某个策略的数据包就按照该策略中定义的操作进行处理。 注意: 我司产品一个接口最多只能配置一个路由图,在同一个接口上多次配置路 由图,后的路由图会覆盖先前配置的路由图。 【举例】

以下的配置例子中,当快速以太网接口FE0接收到数据报,如果数据报 源地址为10.0.0.1,则设置下一跳为196.168.4.6,如果源地址为20.0.0.1 则设置下一跳为196.168.5.6,否则进行普通转发。 access-list 1 permit 10.0.0.1 access-list 2 permit 20.0.0.1 route-map lab1 permit 10 match ip address 1 set ip next-hop 196.168.4.6 exit route-map lab1 permit 20 match ip address 2 set ip next-hop 196.168.5.6 exit interface GigabitEthernet 0/0 ip policy route-map lab1 exit 【相关命令】 注:route-map配置的相关命令请参考《协议无关命令参考》 ip local policy route-map 要对本地发送的报文启用策略路由,请使用命令ip local policy route-map。该命令的no形式关闭策略路由的应用。 ip local policy route-map route-map no ip local policy route-map

(完整版)锐捷交换机命令大全

【第一部分】交换机支持的命令: 1.交换机基本状态: switch: ;ROM状态,路由器是rommon> hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;接口状态 2.交换机口令设置: switch>enable ;进入特权模式 switch#config terminal ;进入全局配置模式 switch(config)#hostname;设置交换机的主机名 switch(config)#enable secret xxx ;设置特权加密口令 switch(config)#enable password xxa ;设置特权非密口令 switch(config)#line console 0 ;进入控制台口 switch(config-line)#line vty 0 4 ;进入虚拟终端 switch(config-line)#login ;允许登录 switch(config-line)#password xx ;设置登录口令xx switch#exit ;返回命令 3.交换机VLAN设置: switch#vlan database ;进入VLAN设置 switch(vlan)#vlan 2 ;建VLAN 2 switch(vlan)#no vlan 2 ;删vlan 2 switch(config)#int f0/1 ;进入端口1 switch(config-if)#switchport access vlan 2 ;当前端口加入vlan 2 switch(config-if)#switchport mode trunk ;设置为干线 switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的vlan switch(config-if)#switchport trunk encap dot1q ;设置vlan 中继switch(config)#vtp domain;设置发vtp域名 switch(config)#vtp password;设置发vtp密码 switch(config)#vtp mode server ;设置发vtp模式 switch(config)#vtp mode client ;设置发vtp模式

锐捷交换机、路由器常用命令

锐捷交换机、路由器常用命令EXEC模式: 用户模式switch> 交换机信息的查看,简单测试命令 特权模式switch# 查看、管理交换机配置信息,测试、调试 配置模式: 全局配置模式switch(config)# 配置交换机的整体参数 接口配置模式switch(config-if)# 配置交换机的接口参数 进入全局配置模式 Switch#c onfigure terminal Switch(config)#exit Switch# 进入接口配置模式 Switch(config)#interface fastethernet 0/1 Switch(config-if)#exit Switch(config)# 从子模式下直接返回特权模式 Switch(config-if)#end

Switch# 命令行其他功能 获得帮助 switch#? switch#show ? 命令简写 全写:switch# configure terminal 简写:Switch# config 使用历史命令 Switch# (向上键) Switch# (向下键) 配置交换机Telnet功能 配置远程登陆密码 Switch(config)#enable secret level 1 0 ruijie 配置进入特权模式密码 Switch (config)#enable secret level 15 0 ruijie

为交换机配置管理IP Switch (config)#interface vlan 1 Switch (config-if)#no shutdown Switch (config-if)#ip address 192.168.1.1 255.255.255.0 Switch (config-if)#end 配置文件的管理 保存配置 将当前运行的参数保存到flash 中用于系统初始化时初始化参数 Switch#copy running-config startup-config Switch#write memory Switch#write 删除配置 永久性的删除flash 中不需要的文件 使用命令delete flash:config.text 删除当前的配置:在配置命令前加no 例:switch(config-if)# no ip address 查看配置文件内容 Switch#show configure 查看保存在FLASH里的配置信息

交换机路由器常用配置操作

锐捷交换机路由器常用配置操作 1.1 通过TELNET方式来配置设备 提问:如何通过telnet方式来配置设备? 回答: 步骤一:配置VLAN1的IP地址 S5750>en ----进入特权模式 S5750#conf ----进入全局配置模式 S5750(config)#int vlan 1 ----进入vlan 1接口 S5750(config-if)#ip address 192.168.0.230 255.255.255.0 ----为vlan 1接口上设置管理ip S5750(config-if)#exit ----退回到全局配置模式 步骤二:配置telnet密码 S5750(config)#line vty 0 4 ----进入telnet密码配置模式 S5750(config-line)#login ---启用需输入密码才能telnet成功 S5750(config-line)#password rscstar ----将telnet密码设置为rscstar S5750(config-line)#exit ----回到全局配置模式 S5750(config)# enable secret level 15 0 rscstar ----配置进入特权模式的密码为rscstar 1.2 更改IOS命令的特权等级 提问:如何只允许dixy这个用户使用与ARP相关的命令? 回答: S5750(config)#username dixy password dixy ----设置dixy用户名和密码 S5750(config)#username dixy privilege 10 ----dixy帐户的权限为10 S5750(config)#privilege exec level 10 show arp ----权限10可以使用show arp命令 S5750(config)#privilege config all level 10 arp ----权限10可以使用所有arp打头的命令S5750(config)#line vty 0 4 ----配置telnet登陆用户 S5750(config-line)#no password S5750(config-line)#login local 1.3设备时钟设置 提问:如何设置设备时钟? 回答: S5750#clock set 12:45:55 11 25 2008 ----设置时间为2008年11月25日12点45分55秒S5750#clock update-calendar ----设置日历更新 S5750(config)#clock timezone CN 8 22 ----时间名字为中国,东8区22分 2.1 交换机vlan和trunk的配置 提问:如何在交换机上划分vlan,配置trunk接口? 回答: 步骤一:给交换机配置IP地址 S2724G#conf S2724G(config)#int vlan 1 S2724G(config-if)#ip addess 192.168.0.100 255.255.255.0----给VLAN 1配置IP地址

锐捷路由器RSR10&20命令参考 第十部份 拨号配置命令参考

RGNOS?命令参考手册拨号配置

目录 1. 第一章配置拨号命令 (1) 1.1拨号相关命令 (1) 1.1.1 async mode (2) 1.1.2 chat-script (3) 1.1.3 clear counters (4) 1.1.4 clear dialer (6) 1.1.5 clear interface (6) 1.1.6 clear line (7) 1.1.7 debug async (7) 1.1.8 debug chat (8) 1.1.9 debug dialer (8) 1.1.10 debug ppp (8) 1.1.11 debug isdn (9) 1.1.12 dialer callback-secure (9) 1.1.13 dialer enable-timeout (10) 1.1.14 dialer fast-idle (11) 1.1.15 dialer-group (12) 1.1.16 dialer hold-queue (13) 1.1.17 dialer idle-timeout (13) 1.1.18 dialer in-band (14) 1.1.19 dialer-list (15) 1.1.20 dialer load-threshold (16) 1.1.21 dialer map (17) 1.1.22 dialer pool (18) 1.1.23 dialer pool-member (19) 1.1.24 dialer priority (20) 1.1.25 dialer remote-name (21) 1.1.26 dialer rotary-group (21) 1.1.27 dialer string (22) 1.1.28 dialer watch-group (23) 1.1.29 dialer watch-list (24) 1.1.30 dialer watch-list delay (25) 1.1.31 group-range (27) 1.1.32 ip address negotiated (27) 1.1.33 ip address-pool (28) 1.1.34 ip route (29) 1.1.35 line (29) 1.1.36 map-class dialer (30) 1.1.37 modem dialin (31) 1.1.38 modem inout (32) 1.1.39 peer default ip address (33) 1.1.40 ppp callback (34)

锐捷交换机常用配置基础命令(实验用)

一、交换机基本配置 ? 交换机命名: 在项目实施的时候,建议为处于不同位置的交换机命名,便于记忆,可提高后期管理效率。 switch(config)#hostname ruijie //ruijie为该交换机的名字 ? 交换机配置管理密码: 配置密码可以提高交换机的安全性,另外,telnet登录交换机的时候,必须要求有telnet管理密码。 switch (config)#enable secret level 1 0 rg //配置telnet管理密码为rg,其中1表示telnet密码,0表示密码不加密 switch (config)#enable secret level 15 0 rg //配置特权模式下的管理 密码rg,其中15表示为特权密码 ? 交换机配置管理IP switch (config)#interface vlan 1 //假设管理VLAN为VLAN 1 switch (config-if)#ip address 192.168.1.1 255.255.255.0 //给管理VLAN配置管理IP地址 switch (config-if)#no shutdown //激活管理IP,养成习惯,无论配置什么设备,都使用一下这个命令 ? 交换机配置网关: switch(config)#ip default-gateway 192.168.1.254 //假设网关地址为192.168.1.254,此命令用户二层设备。 通过以上几个命令的配置,设备便可以实现远程管理,在项目实施

时(尤其是设备位置比较分散)特别能提高效率。 1.1 接口介质类型配置 锐捷为了降低SME客户的总体拥有成本,推出灵活选择的端口形式:电口和光口复用接口,方便用户根据网络环境选择对应的介质类型。 但光口和电口同时只能用其一,如图1,如使用了光口1F,则电口1不能使用。 接口介质类型的转换: Switch(config)#interface gigabitethernet 0/25-28 Interface fastethernet 0/2 Switch(config-if)#medium-type fiber //把接口工作模式改为光口Switch(config-if)#medium-type copper //把接口工作模式改为电口? 默认情况下,接口是工作在电口模式 ? 在项目实施中,如果光纤模块指示灯不亮,工作模式是否正确也是故障原因之一。 1.2 接口速度/双工配置 命令格式: Switch(config)#interface interface-id //进入接口配置模式 Switch(config-if)#speed {10 | 100 | 1000 | auto } //设置接口的速率参数,或者设置为auto Switch(config-if)#duplex {auto | full | half} //设置接口的双工模式? 1000只对千兆口有效;

锐捷交换机常用操作命令手册

锐捷交换机常用操作命令手册 目录 一、交换机配置模式介绍3 二、交换机基本配置3 2.1 接口介质类型配置4 2.2 接口速度/双工配置5 2.3 VLAN配置6 2.4 端口镜像9 2.5 端口聚合10 2.6 交换机堆叠11 2.7 ACL配置12 2.8 端口安全14 2.9 交换机防攻击配置16 2.10 dhcp配置21 2.11 三层交换机配置22 三、交换机常用查看命令24 一、交换机配置模式介绍 交换机配置模式主要有: ? 用户模式:此模式只可以简 单的查看一些交换机的配置和一些简单的修改。 Switch> ? 特权模式:此模式可以查看一些交换机的配置,后面讲述的很多show命令便是在此模式下进行的,还可以对一些简单的设置配置,例如时间。

Switch> enable //在用户模式下输入enable将进入配置模式 Switch# ? 全局配置模式:此模式下可以进行对交换机的配置,例如:命名、配置密码、设路由等。 Switch#configure erminal //特权模式下可以通过config terminal 命令进入配置模式 Switch(config)# ? 端口配置模式:此模式下对端口进行配置,如配置端口ip等。 Switch(config)#interface gigabitEthernet 1/1 //配置模式下输入interface gigabitEthernet 1/1进入到端口g 1/1接口模式。 二、交换机基本配置 ? 交换机命名: 在项目实施的时候,建议为处于不同位置的交换机命名,便于记忆,可提高后期管理效率。 switch(config)#hostname ruijie //ruijie为该交换机的名字 ? 交换机配置管理密码: 配置密码可以提高交换机的安全性,另外,telnet登录交换机的时候,必须要求有telnet管理密码。 switch (config)#enable secret level 1 0 rg //配置 telnet管理密码为rg,其中1表示telnet密码,0表示密码不加密 switch (config)#enable secret level 15 0 rg //配置特权模式下的管理密码rg,其中15表示为特权密码 ? 交换机配置管理IP switch (config)#interface vlan 1 //假设管理VLAN为VLAN 1 switch (config-if)#ip address 192.168.1.1 255.255.255.0 //给管理VLAN配置管理IP地址 switch (config-if)#no shutdown //激活管理 IP,养成习惯,无论配置什么设备,都使用一下这个命令 ? 交换机配置网关:

锐捷NBR系列路由器用户手册V

? 锐捷NBR系列路由器用户手册 V1.7

版权声明 福建星网锐捷网络有限公司?2000-2010 版权所有,保留一切权利。 本手册所有权益由福建星网锐捷网络有限公司独家拥有。没有 经过本公司书面许可,任何单位和个人不得擅自摘抄、复制本 书内容的部分或者全部,并且不得以任何形式传播。 福建星网锐捷网络有限公司保留以后对本手册描述的产品和手 册内容进行升级改进的权利,恕不另行通知。 RGOS?、RGNOS?、锐捷?、?、?、 ?、? 都是福建星网锐捷网络有限公司的注 册商标,不得仿冒。 免责声明: 本手册依据现有信息制作,其内容如有更改,恕不另行通知,请关注锐捷网络有限公司网站提供的最新信息。锐捷网络有限公司在编写本手册时已尽力保证其内容准确可靠,但对于本手册中的遗漏、不准确或错误,以及由此导致的损失和损害,锐捷网络有限公司不承担责任。

前言 版本说明 本手册适用于锐捷NBR系列RG-NBR80, RG-NBR1100E, RG-NBR1200, RG-NBR1100G, RG-NBR1200G, RG-NBR2000, RG-NBR2500和RG-NBR3000 路由器。 内容介绍 这份手册主要介绍了锐捷NBR系列路由器的硬件特性、常用功能的软件配置以及常 见故障的排除等。 在安装路由器之前及安装过程中为避免可能出现的设备损坏和人身伤害,请仔细阅 读本手册。 建议: 建议由熟悉电气环境、线缆连接以及有实际安装和配置路由器经验的专业技术人员 进行安装和配置。 这份手册包括以下章节: z第一章产品介绍 介绍了锐捷NBR系列路由器的外观图以及系统特性; z第二章安装路由器前的准备 描述了安装路由器的环境要求、安装前和安装过程中需要注意的事项、安装所需工 具。 z第三章路由器的安装 介绍路由器的机械安装方法、电源连接方法、配置口电缆连接方法; z第四章快速配置指导 介绍如何启动并对路由器、搭建路由器的配置环境以及针对网吧的不同应用模式如 何进行快速配置;

锐捷交换机命令

锐捷交换机配置命令 交换机基本操作 1.进入特权模式 Switch>enable Switch# 2.返回用户模式 Switch#exit Press RETURN to get started! Switch> 配置模式: 全局配置模式[主机名(config)#]:配置交换机的整体参数 子模式: 1.线路配置模式[主机名(config-line)#]:配置交换机的线路参数 2.接口配置模式[主机名(config-if)#]:配置交换机的接口参数 1.进入全局配置模式下 Switch#configure terminal Switch(config)#exit Switch# 2.进入线路配置模式 Switch(config)#line console 0 Switch(config-line)#exit Switch(config)# 3.进入接口配置模式 Switch(config)#interface fastEthernet 0/1 Switch(config-if)#exit Switch(config)# 从子模式下直接返回特权模式 Switch(config-if)#end Switch# 交换机操作帮助特点: 1.支持命令简写(按TAB键将命令补充完整) 2.在每种操作模式下直接输入“?”显示该模式下所有的命令 3.命令空格“?”显示命令参数并对其解释说明 4.字符“?”显示以该字符开头的命令 5.命令历史缓存: (Ctrl+P)显示上一条命令,(Ctrl+N)显示下一条命令 6.错误提示信息 交换机显示命令: 显示交换机硬件及软件的信息Switch#show version 显示当前运行的配置参数Switch#show running-config 显示保存的配置参数Switch#show configure 常用交换机EXEC命令 将当前运行的配置参数复制到flash:Switch#write memory Building configuration... [OK]

锐捷交换机配置命令

锐捷交换机配置命令 交换机基本操作: 1.进入特权模式 Switch>enable Switch# 2.返回用户模式 Switch#exit Press RETURN to get started! Switch> 配置模式: 全局配置模式[主机名(config)#]:配置交换机的整体参数 子模式: 1.线路配置模式[主机名(config-line)#]:配置交换机的线路参数 2.接口配置模式[主机名(config-if)#]:配置交换机的接口参数 1.进入、退出全局配置模式 Switch#configure terminal Switch(config)#exit Switch# 2.进入、退出线路配置模式 Switch(config)#line console 0 Switch(config-line)#exit Switch(config)# 3.进入、退出接口配置模式 Switch(config)#interface fastEthernet 0/1 Switch(config-if)#exit Switch(config)#

从子模式下直接返回特权模式 Switch(config-if)#end Switch# 交换机操作帮助: 1.支持命令简写(按TAB键将命令补充完整) 2.在每种操作模式下直接输入“?”显示该模式下所有的命令 3.命令空格“?”显示命令参数并对其解释说明 4. “字符?”显示以该字符开头的命令 5.命令历史缓存: (Ctrl+P)显示上一条命令,(Ctrl+N)显示下一条命令 6.错误提示信息 交换机显示命令: 显示交换机硬件及软件的信息 Switch#show version 显示当前运行的配置参数 Switch#show running-config 显示保存的配置参数 Switch#show configure 常用交换机EXEC命令: 1.将当前运行的配置参数复制到flash: Switch#write memory Building configuration... [OK] Switch# 2.清空flash中的配置参数: Switch#delete flash:config.text Switch# 3.交换机重新启动:

锐捷路由器命令全集(互联网+)

命令描述 Access-enable 创建一条临时的访问控制列表条目 Access-template 创建一条临时的访问控制列表条目 Appn 向APPN子系统发送一条命令 Atmsig 执行有关ATM信令的命令 B 手动引导操作系统 Bandwidth 设置接口的带宽 Banner motd 指定日期信息标语 Bfe 设置手工紧急模式 Boot system 指定路由器启动时加载的系统映象 Calendar 管理硬件的日志 Cd 改变妆当前的设备 Cdp enable 允许接口运行CDP协议 Clear 将变量清空 Clear counters 消除接口计数器 Clock 管理系统的时钟 Clock rate 设置串口硬件接口连接时钟速率,如:网络接口模块、处理器能接收的速率 Cmt 启动和停止FDDI连接管理 Config-register 修改配置寄存器设置 Configure 进入全局配置模式 Configure memory 从NVRAM加载配置信息Configure terminal 从终端进行手动配置 Connect 打开一个终端连接 Copy 拷贝配置或映像数据 Copy startup-config running-config 从NVRAM加载配置信息 Copy flash ftp 备份系统映象文件到TFTP服务器 Copy running-config startup-config 将RAM中的当前配置存储到NVRAM Copy running-config tftp 将RAM中的当前配置存储到网络TFTP服务器上Copy tftp flash 从TFTP服务器上下载新映象到Flash Copy tftp running-config 从TFTP服务器上下载配置文件 Debug 使用调试功能(与unduebug相反) Delete 删除一个文件 Dir 列出给定设备上的文件 Disable 退出特模式 Disconnect 关闭一个已经存在的网络连接 Enable 进入特许模式

相关主题
文本预览
相关文档 最新文档