当前位置:文档之家› 路由器配置命令

路由器配置命令

路由器配置命令
路由器配置命令

CCNA命令一、路由器的基本配置模式和简单查看命令

--配置模式提示符

Router>

//用户EXEC模式

Router#

//特许EXEC模式

Router(config)#

//全局配置模式

Router(config-if)#

//接口模式

Router(config-subif)#

//子接口模式

Router(config-line)#

//线程模式

Router(config-router)#

//路由模式

--设置主机名:

router(config)#hostname Set-Hostname

router(config)#^z

--设置用户模式密码:

router(config)#line console0

router(config-line)#login

router(config-line)#password Set-Password

//配置进入用户模式的密码

router(config-line)#logging synchronous

//输入同步

router(config-line)#exec-timeout00

//禁止因为一段时间没有输入而跳出

router(config-line)#^z

--设置特权模式密码:

router(config)#enable password Set-Password

//不加密的密码,明码

router(config)#enable secret Set-Password

//经过加密的密码

router(config)#^z

给所有密码加密:

router(config)#service password-ancryption Set-Password-Here

router(config)#no service password-ancryption

//取消加密

router(config)#^z

--路由器标识配置

Router(config)#hostname<路由器名称,如:Tokyo>Tokyo#/*登录标题*/

Router(config)#banner motd#<欢迎信息,如:Welcome!!!>#

Router(config)#/*接口描述*/

Router(config)#interface Ethernet0

Router(config-if)#description<接口描述信息>

--定位Cisco IOS软件

先从此启动Router#configure terminal

Router(config)#boot system flash

Router(config)#boot system tftptftp_address

Router(config)#boot system rom

Router(config)#end

Router#copy running-config startup-config

--ip host命令

Router(config)#ip host[tcp-port-number]

(注:建立类于建立DNS服务器)

--查看路由器基本显示命令

Show flash

//显示闪存设备的信息

Show processes

//显示有关活动进程的信息

Show processes cpu

//显示CPU活动进程的信息

Show memory

//显示有关路由器内存的统计信息,包括内存空闲的统计信息

Show protocols

//显示已经配置的协议。该命令能显示所配置的任何一种3层(网络层)协议的状态Show interface

//显示路由器上进行了配置的所有端口的统计信息

Show arp

//显示路由器的IP到MAC(接口的)地址映射

--路由器启动和设置与路由器启动相关的命令Router#show startup-config

//显示启动配置文件Router#show running-config

//显示当前配置文件Router#erase startup-config

//删除启动配置Router#write erase

//删除当前配置Router#reload

//重新启动

--启动接口,分配IP地址:

router>

router>enable

router#configure terminal

router(config)#interface Type Port

router(config-if)#no shutdown

router(config-if)#ip address IP-Address Subnet-Mask

router(config-if)#^z

--配置特定的接口

Router(config)#interface serial1/0

Router(config-if)#no shutdown

Router(config-if)#bandwidth56

//设置该接口带宽

router#show controllers Type Port

//确定DCE接口

router(confin-if)#clock rate64000

/进入DCE接口设置时钟速率

router(config-if)#^z

--子接口配置:

router(config-if)#interface Type Port.Subininterface-Number[multipoint|point-to-point] router(config-subif)#ip unnumbered Interface

router(config-subif)#frame-lelay local-dlci Number

router(config-if)#^z

--Telnet:

routerA#telnet IP-Address[Router-Name]

//Telnet到指定的地址或名字的主机

routerB#[exit|logout]

//退出Telnet

routerA#show sessions

//显示当前所有Telnet的信息,包括Connect-Number

routerA#show user

//显示Telnet到本机的连接信息

routerA#clear line[0|1|2|3|4]

//断开指定Telnet到本机的连接

禁止任何Telnet到本机:

router(config)#line vty04

router(config-line)#access-class ACL-Number

router(config)#^z

设置Telnet密码:

router(config)#line vty04

router(config-line)#login

router(config-line)#password Set-Password

router(config-line)#^z

--CDP:

router(config-if)#cdp enable

//在指定端口启用CDP,缺省

router(config-if)#no cdp enable

//在指定端口关闭CDP

router(config)#cdp run

//使所有端口启用CDP

router(config)#no cdp run

//使所有端口关闭CDP

--查看路由器的信息

R1#show clock

//查看配置的时钟。

R1#sh history

//查看在路由器上最近输入的命令。

R1#sh terminal

//查看终端历史记录的大小。

R1#terminal history size

//将历史记录的大小改为22条。

R1#sh version

//显示路由器的版本信息。

R1#sh session

//显示会话记录,经常在终端上使用。

R1#sh startup-config

//显示下次路由器重新加载时将要使用的配置。

R1#sh running-config

//显示当前的配置信息。

R1#copy run star

//保存当前的配置作为启动时的配置。

二、路由协议命令

--静态路由:

Router(config)#ip route目的网络+掩码[下一跳address|本地接口][distance][permanent]

//配置静态路由(下一跳地址和本地接口;Distance范围:1~255,相当于优先权,越小越好。RIP=120;DSPF=110;IEIGRP=90)

--缺省路由:

Router(config)#ip route0.0.0.00.0.0.0[下一跳address|本地接口][distance][permanent]

Router(config)#ip classless

Router(config)#no ip classless

//配置默认路由(ip classless)

--动态缺省路由:

router(config)#ip defoult-network IP-Address

--RIP:

routerX(config)#router rip

//启动RIP路由进程

routerX(config-router)#version2

//启动RIP的版本号为2(如果要是不写此命令默认RIPv1)

routerX(config-router)#network x.x.x.x

//宣告接口的网络

routerX(config-if)#ip rip receive version12

//定义接受的RIP路由信息的版本号

routerX#sh ip protocols

//显示关于路由协议的值及协议计时器等信息

routerX#sh ip interface brief

//获取所有接口IP信息和状态的摘要

show ip route

10.0.0.0/30is subnetted,7subnets

R10.7.7.0[120/1]via10.4.4.1,00:00:07,Serial1/2

R10.6.6.0[120/1]via10.4.4.1,00:00:07,Serial1/2

R10.3.3.0[120/2]via10.1.1.2,00:00:03,Serial1/1

[120/2]via10.4.4.1,00:00:07,Serial1/2

R10.5.5.0[120/1]via10.1.1.2,00:00:03,Serial1/1

//120RIP路由协议的管理距离,1是度量值,10.1.1.2是通往目的地经过的下一ROUTER的接口地址NEXT HOP Serial1/1连接NEXT HOP的本机接口

routerX#debug ip rip

//显示发送和接受RIP路由更新

routerX#undebug all(no debug all)

//关闭调试

--OSPF:

routerX(config)#router ospf?

<1-65535>Process ID

//激活ospf进程

routerX(config-router)#network Network number wildcard-mask area-ID

//将网络分配到指定ospf区域

routerX#sh ip protocols

//检验是否已配置ospf

routerX#sh ip route

//显示路由信息

routerX#sh ip ospf

//显示ospf路由器ID、计时器和统计信息

routerX#sh ip ospf interface

//显示区域ID和邻接信息

routerX#sh ip ospf neighbor

//显示每个接口上的ospf邻居信息

routerX#debug ip ospf events

//获取ospf报文事件

routerX#debug ip ospf packet

//显示ospf报文信息

routerX(config-router)#maximum-paths?

<1-16>Number of paths

//配置ospf负载均衡

routerX(config-if)#ip ospf cost?

<1-65535>Cost

//配置ospf的链路开销

routerX(config-if)#ip ospf authentication?

message-digest Use message-digest authentication null Use no authentication

//指定接口身份验证类型

routerX(config-router)#area X authentication? message-digest Use message-digest authentication //指定区域的身份验证类型

routerX(config-if)#ip ospf authentication-key password //分配用于邻居路由器的口令

--EIGRP:

routerX(config)#router eigrp?

<1-65535>Autonomous system number

//激活eigrp进程

routerX(config-router)#network?

A.B.C.D Network number

//宣告eigrp的网段

routerX#sh ip route eigrp

//显示路由表中的当前eigrp条目

routerX#sh ip protocols

//显示活动进程的参数和当前状态

routerX#sh ip eigrp interfaces

//显示为eigrp配置的接口信息

routerX#sh ip eigrp neighbors

//显示eigrp发现的邻居

routerX#sh ip eigrp topology

//显示eigrp的拓扑表

routerX#sh ip eigrp traffic

//显示发送和接受eigrp数据包数量

routerX#debug ip eigrp

//获取eigrp的报文信息

routerX(config-router)#maximum-paths?

<1-16>Number of paths

//配置负载均衡

routerX(config-router)#variance?

<1-128>Metric variance multiplier

//配置不等价负载均衡

routerX(config)#key chain?

WORD Key-chain name

routerX(config-keychain)#key?

<0-2147483647>Key identifier

routerX(config-keychain-key)#key-string?

0Specifies an UNENCRYPTED password will follow

7Specifies a HIDDEN password will follow

//配置密钥

routerX(config-if)#ip authentication mode eigrp12md5

//为eigrp数据包指定MD5身份验证

routerX(config-if)#ip authentication key-chain eigrp12hehe

//使用密匙链中的密钥来启用eigrp数据包的身份验证

三、交换基本命令

--vlan:

Switch(config)#vlan?

<1-1005>ISL VLAN IDs1-1005

Switch(config-vlan)#name?

WORD The ascii name for the VLAN

//创建vlan

Switch(config-if)#switchport mode access

//把端口定义为二层接入端口

Switch(config-if)#switchport access vlan?

<1-1005>

//把端口分配进特定的vlan里

注意:假如把端口分配到了不存在的vlan里,那么新vlan将被自动创建

Switch(config-if)#switchport mode trunk

//配置中继端口模式(用于在switch之间传递多个vlan的数据)

Switch(config-if)#switchport trunk allowed?

vlan Set allowed VLANs when interface is in trunking mode

//指定trunk链路通过的vlan

注意:cisco默认全部允许

Switch(config-if)#switchport trunk allowed vlan remove vlan-list

//将某VLAN从中继中删除

Switch(config-if)#switchport trunk allowed vlan add vlan-list

//添加某个VLAN到中继线路

Switch(config-if)#switchport trunk native vlan?

<1-1005>

//指定trunk口的本地vlan(如果数据帧所属vlan ID与native vlanID相同,则数据帧不打标签直接传递)

Switch#sh vlan?

brief VTP all VLAN status in brief

id VTP VLAN status by VLAN id

name VTP VLAN status by VLAN name

//查看vlan详细信息

Switch(config)#ip default-gateway

//设置该交换机的默认网关

--vtp:

Switch(config)#vtp mode?

client Set the device to client mode.

server Set the device to server mode.

transparent Set the device to transparent mode.

//定义vtp模式(默认是server)

Switch(config)#vtp domain?

WORD

//定义vtp域名(在同一个vlan管理域的switch的域名必须相同)Switch(config)#vtp password?

WORD

//设置vtp密码(同一个vtp域里的switch的vtp域密码的密码必须一致)Switch(config)#show vtp

//显示一台交换机的VTP配置

--vlan间单臂路由:

Router(config)#int f0/0.1

//创建子接口

Router(config-subif)#encapsulation dot1Q?

<1-1005>IEEE802.1Q VLAN ID

//指定封装类型及vlan号

Router(config-subif)#ip address?

A.B.C.D

//配置vlan的网关地址

--vlan间路由-三层交换

Switch(config)#int vlan?

<1-1005>

//在三层switch创建SVI接口

Switch(config-if)#ip address

//在接口下配置IP地址

Switch(config)#ip routing

//开启路由功能(switch路由功能是关闭)

--STP:

Switch(config)#spanning-tree mode?

pvst Per-Vlan spanning tree mode

rapid-pvst Per-Vlan rapid spanning tree mode

//选择stp模式(cisco默认开启pvst+模式)

Switch(config-if)#spanning-tree portfast

//在接口上配置pvst

Switch#show spanning-tree vlan vlan#[detail]

//验证stp的配置

Switch#debug spanning-tree pvst+

//调试stp

SwitchA(config)#spanning-tree vlan1root primary

//对于vlan1这个交换机是根交换

SwitchA(config)#spanning-tree vlan2root secondary

//配置该交换机为备份根

--DNS

Router(config)#ip name-server

(注:类似于在客户端指定DNS服务器地址,但指定的DNS服务器最多为6个)24.3.3如何在路由器上启动和停止DNS

Router(config)#ip domain-lookup(注:默认下是启动的)

Router(config)#no ip domain-lookup(注:此为关闭DNS服务)

--验证地址配置

Router#Telnet{DNS主机名|IP地址}

Router#ping{DNS主机名|IP地址}

字符定义

!成功接收回送应答

.等待数据包应答超时

U目的地不可到达错误

C数据包遇到拥塞

I Ping被中断(例如:Ctrl+Shift+6+X)

?数据包类型未知

&超过数据包生存时间(TTL)

Router#trace{DNS主机名|IP地址}

响应定义!H

路由器接收到探测数据包,但没有转发,通常是由访问控制列表造成的

P协议不可达

N网络不可达

U端口不可达

*超时

--ACL:

配置标准ACL:

router(config)#access-list Access-L ist-Number[permit|deny]source[source-mask] router(config)#interface Type Port

router(config-if)#ip access-group Access-List-Number[in|out]

router(config-if)#^z

配置扩展ACL:

router(config)#a ccess-list Access-List-Number[permit|deny][Protocol|Protocol-Number] source source-wildcard[Source-Port]destination destination-wildcard

[Destination-Port][established]

router(config)#interface Type Port

router(config-if)#ip access-group Access-List-Number[in|out]

router(config-if)#^z

配置命名ACL:

router(config)#ip access-list[standard|extended]ACL-Name

router(config[std-|ext-]nacl)#[permit|deny][IP-Access-List-Test-Conditions] router(config[std-|ext-]nacl)#no[permit|deny][IP-Access-List-Test-Conditions] rouer(config[std-|ext-]nacl)#^z

router(config)#interface Type Port

router(config-if)#ip access-group[ACL-Name|1~199][in|out]

router(config-if)#^z

查看ACL:

router#show ip access-lists

//显示ACL的列表

router#show ip interface Type Port

//显示接口上配置ACL

--NAT:

配置静态转换

Router(config)#ip nat inside source static local-ip global-ip

//建立内部本地地址与内部全局地址间的静态转换

Router(config-if)#ip nat inside

//将该接口标记为连接内部网络的接口

Router(config-if)#ip nat outside

//将该接口标记为连接外部网络的接口

配置动态地址转换

Router(config)#ip nat pool name start-ip end-ip{netmask netmask|prefix-length prefix-length} //定义可根据需要进行分配的全局地址

Router(config)#access-list access-list-number permit source[source-wildcard]

//定义允许那些要被转换的内部本地地址的标准IP AC

Router(config)#ip nat inside source list access-list-number

//建立动态源转换,指定上一步定义的ACL

Router(config-if)#ip nat inside

//将该接口标记为连接内部网络的接口

Router(config-if)#ip nat outside

//将该接口标记为连接外部网络的接口

配置Overload:

Router(config)#access-list access-list-number permit source source-wildcard

//定义允许那些要被转换的内部本地地址的标准IP AC

Router(config)#ip nat inside source list access-list-number interface interface overload

//建立动态源转换,指定上一步定义的ACL

Router#clear ip nat translation

//清除NAT Translation Table

Router#show ip nat translations

//Show命令输出信息

--配置PPP协议:

router(config)#username Name password Set-Password-Here

//验证方建立数据库

router(config)#interface Type Port

router(config-if)#encapsulation ppp

//启动PPP协议(cisco默认是HDLC)

router(config-if)#ppp authentication[chap|chap pap|pap chap|pap]

//选择PPP认证(如果要是两个验证都写的则谁在前选谁)

router(config-if)#ppp pap sent-username Name password Password

//发送验证信息

router(config-if)#^z

--配置Frame Relay:

router(config-if)#encapsulation frame-relay[cisco|ietf]

router(config-if)#frame-relay lmi-type[ansi|cisco|q933a]

router(config-if)#bandwidth kilobits

router(config-if)#frame-relay invers-arp[Protocol][dlci]

配置静态Invers ARP表:

router(config)#frame-relay Protocol Protocol-Address DLCI[Broadcast][ietf|cisco] [payload-compress|packet-by-packet]

设置Keepalive间隔:

router(config-if)#keepalive Numbe

为本地接口指定DLCI:

router(config-if)#frame-lelay local-dlci Number

华三华为交换机路由器配置常用命令汇总定稿版

华三华为交换机路由器 配置常用命令汇总 HUA system office room 【HUA16H-TTMS2A-HUAS8Q8-HUAH1688】

H3C交换机配置命令大全1、system-view 进入系统视图模式 2、sysname 为设备命名 3、display current-configuration 当前配置情况 4、 language-mode Chinese|English 中英文切换 5、interface Ethernet 1/0/1 进入以太网端口视图 6、 port link-type Access|Trunk|Hybrid 设置端口访问模式 7、 undo shutdown 打开以太网端口 8、 shutdown 关闭以太网端口

9、 quit 退出当前视图模式 10、 vlan 10 创建VLAN 10并进入VLAN 10的视图模式 11、 port access vlan 10 在端口模式下将当前端口加入到vlan 10中 12、port E1/0/2 to E1/0/5 在VLAN模式下将指定端口加入到当前vlan中 13、port trunk permit vlan all 允许所有的vlan通过 H3C路由器配置命令大全华为交换机常用配置实例 H3C交换机路由器telnet和console口登录配置 2009年11月09日星期一 10:00

级别说明 Level 名称 命令 参观 ping、tracert、telnet 1 监控 display、debugging 2 配置 所有配置命令(管理级的命令除外)

CISCO路由器基本配置命令

一、 1.router(config)#router rip 启动rip进程 2.router(conifg-router)#network 172.17.0.0指定rip协议的主网络 3.router(config-router)#passive-interface f0/1把f0/1配置成passive端口 4.router(config-router)#neighbor 172.17.12.67 以单波方式通告rip更新给路由器 5.router(config-if)#ip address 192.168.83.244 255.255.255.0 主ip地址 router(config-if)#ip address 10.33.55.1 255.255.255.0 secondary辅助ip地址二、 1.router(config-router)#version 2将rip配置成版本2 2.router(config-ip)#ip rip send version 1只发rip 1数据包 router(config-ip)#ip rip receive version 2只接收rip 2数据包 3.router(config-router)#no auto-summary 关闭汇总功能 4.router(config-if)#no ip split-horizon关闭水平分割 5.router#show ip ospf database router 192.168.30.10显示路由器LSA通告 router#show ip ospf database network 192.168.17.18显示网络LSA通告 router#show ip ospf database summary 172.16.121.0显示网络汇总LSA通告 router#show ip ospf database asbr-summary显示ASBR汇总LSA通告 router#show ip ospf database external 10.83.10.0显示自主系统外部LSA通告router#show ip ospf database nssa-external显示NSSA外部LSA通告 三、 1.router(config)#router ospf 10配置ospf进程id 2.router(config)#interface loopback0

H3C的路由器配置命令详解

H3C的路由器配置命令详解 en 进入特权模式 conf 进入全局配置模式 in s0 进入serial 0 端口配置 ip add xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx 添加ip 地址和掩码,电信分配enca hdlc/ppp 捆绑链路协议hdlc 或者ppp ip unn e0 exit 回到全局配置模式 in e0 进入以太接口配置 ip add xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx 添加ip 地址和掩码,电信分配exit 回到全局配置模式 ip route 0.0.0.0 0.0.0.0 s 0 添加路由表 ena password 口令 write exit 以上根据中国电信ddn 专线多数情况应用 普通用户模式 enable 转入特权用户模式 exit 退出配置 help 系统帮助简述 language 语言模式切换 ping 检查网络主机连接及主机是否可达 show 显示系统运行信息 telnet 远程登录功能 tracert 跟踪到目的地经过了哪些路由器 特权用户模式 #? clear 清除各项统计信息

clock 管理系统时钟 configure 进入全局配置模式 debug 开启调试开关 disable 返回普通用户模式 download 下载新版本软件和配置文件 erase 擦除FLASH中的配置 exec-timeout 打开EXEC超时退出开关 exit 退出配置 first-config 设置或清除初次配置标志 help 系统帮助简述 language 语言模式切换 monitor 打开用户屏幕调试信息输出开关 no 关闭调试开关 ping 检查网络主机连接及主机是否可达 reboot 路由器重启 setup 配置路由器参数 show 显示系统运行信息 telnet 远程登录功能 tracert 跟踪到目的地经过了哪些路由器unmonitor 关闭用户屏幕调试信息输出开关write 将当前配置参数保存至FLASH MEM中 全局配置模式 aaa-enable 使能配置AAA(认证,授权和计费) access-list 配置标准访问表 arp 设置静态ARP人口 chat-script 生成一个用在modem上的执行脚本custom-list 创建定制队列列表 dialer-list 创建dialer-list dram-wait 设置DRAM等待状态

cisco路由器配置及维护手册

cisco路由器配置及维护手册 作者:pixfire 一、路由器简单配置 1. 用串行电缆将PC机串口与路由器CONSOLE口连接,用WIN95的超级终端或NETTERM 软件进行配置。PC机串口设置为波特率9600 数据位8 停止位1。 2. 新出厂的路由器启动后会进入自动配置状态。可按提示对相应端口进行配置。 3 . 命令行状态。若不采用自动配置,可在自动配置完成后,题问是否采用以上配置时,回答N。此时进入命令行状态。 4 进入CONFIG模式。在router>键入enable , 进入router # ,再键入config t ,进入 router(config)# 。 5 配置广域端口。在正确连接好与E1端口的电缆线后,在router # 下键入sh controller cbus 。检验端口物理特性,及连线是否正确。之后,进入config模式。 进行以下配置。 int serial <端口号> E1端口号。 ip address <掩码> 广域网地址 bandwidth 2000 传输带宽 clock source line 时钟设定。 6 检验配置。设置完成后,按ctrl Z退出配置状态。键入write mem 保存配置。 用sh conf 检查配置信息。用sh int 检查端口状态。 二、路由器常用命令 2.1 Exec commands: <1-99> 恢复一个会话 bfe 手工应急模式设置 clear 复位功能

clock 管理系统时钟 configure 进入设置模式 connect 打开一个终端 copy 从tftp服务器拷贝设置文件或把设置文件拷贝到tftp服务器上 debug 调试功能 disable 退出优先命令状态 disconnect 断开一个网络连接 enable 进入优先命令状态 erase 擦除快闪内存 exit 退出exce模式 help 交互帮助系统的描述 lat 打开一个本地传输连接 lock 锁定终端 login 以一个用户名登录 logout

路由器配置常用命令汇总

Access-enable允许路由器在动态访问列表中创建临时访问列表入口 Access-group把访问控制列表(ACL)应用到接口上 Access-list定义一个标准的IP ACL Access-template在连接的路由器上手动替换临时访问列表入口 Appn向APPN子系统发送命令 Atmsig执行ATM信令命令 B 手动引导操作系统 Bandwidth 设置接口的带宽 Banner motd 指定日期信息标语 Bfe 设置突发事件手册模式 Boot system 指定路由器启动时加载的系统映像 Calendar 设置硬件日历 Cd 更改路径 Cdp enable 允许接口运行CDP协议 Clear 复位功能 Clear counters 清除接口计数器 Clear interface 重新启动接口上的件逻辑 Clockrate 设置串口硬件连接的时钟速率,如网络接口模块和接口处理器能接受的速率Cmt 开启/关闭FDDI连接管理功能 Config-register 修改配置寄存器设置 Configure 允许进入存在的配置模式,在中心站点上维护并保存配置信息 Configure memory 从NVRAM加载配置信息 Configure terminal 从终端进行手动配置 Connect 打开一个终端连接

Copy 复制配置或映像数据 Copy flash tftp 备份系统映像文件到TFTP服务器 Copy running-config startup-config 将RAM中的当前配置存储到NVRAM Copy running-config tftp 将RAM中的当前配置存储到网络TFTP服务器上 Copy tftp flash 从TFTP服务器上下载新映像到Flash Copy tftp running-config 从TFTP服务器上下载配置文件 Debug 使用调试功能 Debug dialer 显示接口在拨什么号及诸如此类的信息 Debug ip rip 显示RIP路由选择更新数据 Debug ipx routing activity 显示关于路由选择协议(RIP)更新数据包的信息 Debug ipx sap 显示关于SAP(业务通告协议)更新数据包信息 Debug isdn q921 显示在路由器D通道ISDN接口上发生的数据链路层(第2层)的访问过程 Debug ppp 显示在实施PPP中发生的业务和交换信息 Delete 删除文件 Deny 为一个已命名的IP ACL设置条件 Dialer idle-timeout 规定线路断开前的空闲时间的长度 Dialer map 设置一个串行接口来呼叫一个或多个地点 Dialer wait-for-carrier-time 规定花多长时间等待一个载体 Dialer-group 通过对属于一个特定拨号组的接口进行配置来访问控制 Dialer-list protocol 定义一个数字数据接受器(DDR)拨号表以通过协议或ACL与协议的组合来控制控制拨号 Dir 显示给定设备上的文件 Disable 关闭特许模式 Disconnect 断开已建立的连接

Cisco路由器的基本配置命令

Cisco路由器的基本配置命令 Cisco 路由器的基本配置命令 一(实训目的 1(掌握路由器的连接方式和使用基本规则。 2(掌握路由器的基本配置命令。 二(实训器材及环境 1(安装 Windows 2000 Server 系统的计算机一台。 2(安装模拟软件 Boson Netsim 5.31。 3(模拟环境如下: 图 11-1 实验拓扑环境 三(实训理论基础 1(路由器的基本配置语句 (1)配置路由器名字和特权密码: Router1> enable Router1# conf t Router1(config)# hostname R1 R1(config)# enable secret 123456
b5E2RGbCAP
(2)配置路由器的 Ethernet 端口:
R1(config)# interface e0 R1(config-if)# ip address 192.168.1.1 255.255.255.0 p1EanqFDPw R1(config-if)# no shutdown (3)配置路由器的 Serial 端口(DTE 端):DXDiTa9E3d R1(config)# interface s0 R1(config-if)# ip address 10.0.0.1 255.0.0.0 R1(config-if)# no shutdown (4)配置路由器的 Serial 端口(DCE 端):
RTCrpUDGiT
R2(config)# interface s0 R2(config-if)# ip address 10.0.0.2 255.0.0.0 R2(config-if)# clock rate 64000 R2(config-if)# no shutdown 2(路由器可以有多种类型的端口,用于连接 不同的网络,常用的有以太网端口(Ethernet)、快速以太网端口 (FastEthernet)、高速同步串口(Serial)等。有的端口是固定端口,有的端
5PCzVD7HxA
- 1 -

H3C路由器配置命令详解

华为H3C路由器交换机配置命令详解 2009-12-28 22:40:13| 分类: Quidway-h3c|举报|字号订阅 交换机命令 [Quidway]super password 修改特权用户密码 [Quidway]sysname 交换机命名 [Quidway]interface ethernet 0/1 进入接口视图 [Quidway]interface vlan x 进入接口视图 [Quidway-Vlan-interfacex]ip address 10.65.1.1 255.255.0.0 配置VLAN的IP地址[Quidway]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2 静态路由=网关 [Quidway]user-interface vty 0 4 进入虚拟终端 [S3026-ui-vty0-4]authentication-mode password 设置口令模式 [S3026-ui-vty0-4]set authentication-mode password simple 222 设置口令 [S3026-ui-vty0-4]user privilege level 3 用户级别 [Quidway-Ethernet0/1]duplex {half|full|auto} 配置端口工作状态[Quidway-Ethernet0/1]speed {10|100|auto} 配置端口工作速率[Quidway-Ethernet0/1]flow-control 配置端口流控 [Quidway-Ethernet0/1]mdi {across|auto|normal} 配置端口平接扭接[Quidway-Ethernet0/1]port link-type {trunk|access|hybrid} 设置端口工作模式[Quidway-Ethernet0/1]undo shutdown 激活端口 [Quidway-Ethernet0/2]quit 退出系统视图 [Quidway]vlan 3 创建VLAN [Quidway-vlan3]port ethernet 0/1 to ethernet 0/4 在VLAN中增加端口[Quidway-Ethernet0/2]port access vlan 3 当前端口加入到VLAN [Quidway-Ethernet0/2]port trunk permit vlan {ID|All} 设trunk允许的VLAN [Quidway-Ethernet0/2]port trunk pvid vlan 3 设置trunk端口的PVID [Quidway]monitor-port 指定镜像端口[Quidway]port mirror 指定被镜像端口[Quidway]port mirror int_list observing-port int_type int_num 指定镜像和被镜像[Quidway]description string 指定VLAN描述字符[Quidway]description 删除VLAN描述字符[Quidway]display vlan [vlan_id] 查看VLAN设置 [Quidway]stp {enable|disable} 设置生成树,默认关闭[Quidway]stp priority 4096 设置交换机的优先级[Quidway]stp root {primary|secondary} 设置为根或根的备份[Quidway-Ethernet0/1]stp cost 200 设置交换机端口的花费 [SwitchA-vlanx]isolate-user-vlan enable 设置主vlan [SwitchA]Isolate-user-vlan secondary 设置主vlan包括的子vlan [Quidway-Ethernet0/2]port hybrid pvid vlan 设置vlan的pvid

华为企业级路由器配置命令大全

华为华为路由器交换机配置命令大全 一、计算机命令 PCAlogin:root;使用root用户 password:linux;口令是linux #shutdown-hnow;关机 #init 0;关机 #logout;用户注销 #login;用户登录 #ifconfig;显示IP地址 #ifconfig eth0 netmask;设置IP地址 #ifconfig eht0 netmask down;禁用IP地址 #route add 0.0.0.0 gw;设置网关 #route del 0.0.0.0 gw;删除网关 #route add default gw;设置网关 #route del default gw;删除网关 #route;显示网关 #ping;发ECHO包 #telnet;远程登录 二、华为路由器交换机配置命令:交换机命令 [Quidway]dis cur;显示当前配置 [Quidway]display current-configuration;显示当前配置 [Quidway]display interfaces;显示接口信息 [Quidway]display vlan;显示vlan信息 [Quidway]display version;显示版本信息 [Quidway]super password;修改特权用户密码 [Quidway]sysname;交换机命名 [Quidway]interface ethernet0/1;进入接口视图 [Quidway]interface vlan x;进入接口视图 [Quidway-Vlan-interfacex]ip address 10.65.1.1 255.255.0.0;配置VLAN的IP地址[Quidway]Ip route-static 0.0.0.0 0.0.0.0 10.65.1.2;静态路由=网关[Quidway]rip; rip协议 [Quidway]local-user ftp [Quidway]user-interface vty 0 4;进入虚拟终端 [S3026-ui-vty0-4]authentication-mode password;设置口令模式 [S3026-ui-vty0-4]set authentication-mode password simple 222;设置口令 [S3026-ui-vty0-4]user privilege level 3;用户级别 [Quidway]interface ethernet0/1;进入端口模式 [Quidway]int e0/1;进入端口模式 [Quidway-Ethernet0/1]duplex{half|full|auto};配置端口工作状态 [Quidway-Ethernet0/1]speed{10|100|auto};配置端口工作速率 [Quidway-Ethernet0/1]flow-control;配置端口流控

路由器常用命令

cisco路由器常用命令 1:三大模式 router> 用户模式 router > enable 进入特权模式 router # router > enable 进入全局配置模式 router #configure terminal router (conf)# 2:其它模式 Router(config)#interface f1/0 进入接口配置模式Router(config-if)# Router(config)#interface f1/0.1 进入子接口配置模式Router(config-subif)# Router(config)#line console 0 进入line模式Router(config-line)# Router(config)#router rip 进入路由模式Router(config-router)# 3:路由器命名 hostname routera,以routerA为例 router > enable router #configure terminal router(conf)#hostname routerA routera (conf)# 4:配置各类密码 配置特权模式密码(使能口令) enable password cisco,以cisco为例 router > enable router #configure terminal router(conf)#hostname routerA routerA (conf)# enable password cisco 设置VTY(虚拟终端接口)密码 Router(config)#line vty 0 1

CISCO路由器配置手册----帧中继(Frame Relay)配置

CISCO路由器配置手册----Frame Relay 1. 帧中继技术 帧中继是一种高性能的WAN协议,它运行在OSI参考模型的物理层和数据链路层。它是一种数据包交换技术,是X.25的简化版本。它省略了X.25的一些强健功能,如提供窗口技术和数据重发技术,而是依靠高层协议提供纠错功能,这是因为帧中继工作在更好的WAN设备上,这些设备较之X.25的WAN设备具有更可靠的连接服务和更高的可靠性,它严格地对应于OSI参考模型的最低二层,而X.25还提供第三层的服务,所以,帧中继比X.25具有更高的性能和更有效的传输效率。 帧中继广域网的设备分为数据终端设备(DTE)和数据电路终端设备(DCE),Cisco 路由器作为 DTE设备。 帧中继技术提供面向连接的数据链路层的通信,在每对设备之间都存在一条定义好的通信链路,且该链路有一个链路识别码。这种服务通过帧中继虚电路实现,每个帧中继虚电路都以数据链路识别码(DLCI)标识自己。DLCI的值一般由帧中继服务提供商指定。帧中继即支持PVC也支持SVC。 帧中继本地管理接口(LMI)是对基本的帧中继标准的扩展。它是路由器和帧中继交换机之间信令标准,提供帧中继管理机制。它提供了许多管理复杂互联网络的特性,其中包括全局寻址、虚电路状态消息和多目发送等功能。 2. 有关命令: 端口设置 任务命令 设置Frame Relay封装encapsulation frame-relay[ietf] 1 设置Frame Relay LMI类型frame-relay lmi-type {ansi | cisco | q933a}2 设置子接口interface interface-type interface-number.subinterface -number [multipoint|point-to-point] 映射协议地址与DLCI frame-relay map protocol protocol-address dlci

路由器配置命令详细列表

启动接口,分配IP地址 router> router> enable router# router# configure terminal router(config)# router(config)# interface Type Port router(config-if)# no shutdown router(config-if)# ip address IP-Address Subnet-Mask router(config-if)# ^z [编辑] 配置RIP路由协议:30秒更新一次

router(config)# router rip router(config-if)# network Network-Number <——通告标准A,B,C类网——> router(config-if)# ^z [编辑] 配置IGRP路由协议:90秒更新一次 router(config)# router igrp AS-Number <—— AS-Number范围1~65535——> router(config-if)# network Network-Number <——通告标准A,B,C类网——> router(config-if)# ^z [编辑] 配置Novell IPX路由协议:Novell RIP 60秒更新一次router(config)# ipx routing [node address] router(config)# ipx maximum-paths Paths <——设置负载平衡,范围1~512——>

router(config)# interface Type Port router(config-if)# ipx network Network-Number [encapsulation encapsulation-type] [secondary] <——通告标准A,B,C类网——> router(config-if)# ^z [编辑] 配置DDR: router(config)# dialer-list Group-Number protocol Protocol-Type permit [list ACL-Number] router(config)# interface bri 0 router(config-if)# dialer-group Group-Number router(config-if)# dialer map Protocol-Type Next-Hop-Address name Hostname Telphone-Number router(config-if)# ^z

思科交换机路由器命令大全

思科交换机路由器命令 大全 YUKI was compiled on the morning of December 16, 2020

1. 交换机支持的命令:交换机基本状态: 交换机口令设置: switch>enable ;进入特权模式switch#config terminal ;进入全局配置模式 switch(config)#hostname ;设置交换机的主机名 switch(config)#enable secret xxx ;设置特权加密口 令switch(config)#enable password xxa ;设置特权非 密口令switch(config)#line console 0 ;进入控制台 口switch(config-line)#line vty 0 4 ;进入虚拟终端 switch(config-line)#login ;允许登录 switch(config-line)#password xx ;设置登录口令 xxswitch#exit ;返回命令 交换机VLAN设置:

switch(vlan)#vlan 2 ;建VLAN 2switch(vlan)#no vlan 2 ;删vlan 2switch(config)#int f0/1 ;进入端 口1switch(config-if)#switchport access vlan 2 ; 当前端口加入vlan 2switch(config-if)#switchport mode trunk ;设置为干线switch(config- if)#switchport trunk allowed vlan 1,2 ;设置允许 的vlanswitch(config-if)#switchport trunk encap dot1q ;设置vlan 中继switch(config)#vtp domain ;设置发vtp域名switch(config)#vtp password ;设置发vtp密码switch(config)#vtp mode server ;设置发vtp模式switch(config)#vtp mode client ;设置发vtp模式 交换机设置IP地址: 交换机显示命令:

华三华为交换机-路由器配置常用命令汇总

欢迎阅读H3C交换机配置命令大全 1、system-view 进入系统视图模式 2、sysname 为设备命名 3、display current-configuration 当前配置情况 4、language-mode Chinese|English 中英文切换 5、interface Ethernet 1/0/1 进入以太网端口视图 6、port link-type Access|Trunk|Hybrid 设置端口访问模式 7、undo shutdown 打开以太网端口 8、shutdown 关闭以太网端口 9、quit 退出当前视图模式 10、vlan 10 创建VLAN 10并进入VLAN 10的视图模式 11、port access vlan 10 在端口模式下将当前端口加入到vlan 10中 12、port E1/0/2 to E1/0/5 在VLAN模式下将指定端口加入到当前vlan中 13、port trunk permit vlan all 允许所有的vlan通过 H3C路由器配置命令大全华为交换机常用配置实例 H3C交换机路由器telnet和console口登录配置 2009年11月09日星期一 10:00 级别说明 Level 名称 命令 参观 ping、tracert、telnet 1 监控 display、debugging

2 配置 所有配置命令(管理级的命令除外) 3 管理 文件系统命令、FTP命令、TFTP命令、XMODEM命令 telnet仅用密码登录,管理员权限 [Router]user-interface vty 0 4[Router-ui-vty0-4]user privilege level 3[Router-ui-vty0-4]set authentication password simple abc telnet仅用密码登录,非管理员权限 [Router]super password level 3 simple super [Router]user-interface vty 0 4[Router-ui-vty0-4]user privilege level 1[Router-ui-vty0-4]set authentication password simple abc telnet使用路由器上配置的用户名密码登录,管理员权限 [Router]local-user admin password simple admin[Router]local-user admin service-type telnet[Router]local-user admin level 3 [Router]user-interface vty 0 4[Router-ui-vty0-4]authentication-mode local telnet使用路由器上配置的用户名密码登录,非管理员权限 [Router]super password level 3 simple super [Router]local-user manage password simple manage[Router]local-user manage service-type telnet[Router]local-user manage level 2 [Router]user-interface vty 0 4[Router-ui-vty0-4]authentication-mode local 对console口设置密码,登录后使用管理员权限 [Router]user-interface con 0[Router-ui-console0]user privilege level 3[Router-ui-console0]set authentication password simple abc 对console口设置密码,登录后使用非管理员权限 [Router]super password level 3 simple super [Router]user-interface con 0[Router-ui-console0]user privilege level 1[Router-ui-console0]set authentication password simple abc 对console口设置用户名和密码,登录后使用管理员权限 [Router]local-user admin password simple admin[Router]local-user admin service-type terminal[Router]local-user admin level 3 [Router]user-interface con 0[Router-ui-console0]authentication-mode local 对console口设置用户名和密码,登录后使用非管理员权限 [Router]super password level 3 simple super [Router]local-user manage password simple manage[Router]local-user

路由器常用配置命令

Cisco常用配置命令Cisco常用配置命令 一.交换机的基本配置 C2950# config terminal 进入全局配置模式 show interface fastethernet0/1 查看端口0/1的配置结果 show interface fastethernet0/1 status 查看端口0/1的状态 show mac-address-table 查看整个MAC地址表 clear mac-address-table restricted static 清除限定性地址 C2950(config)# hostname 2950A / 设置主机名为2950A interface f0/23 / 进入端口23的配置模式 enable password cisco / 设置enable password为cisco enable secret cisco1 / 设置enable secret为cisco1 ip address 192.168.1.1 255.255.255.0 / 设置交换机IP 地址 ip default-gateway 192.168.1.254 / 设置默认网关 ip domain-name https://www.doczj.com/doc/5717187644.html, / 设置域名 ip name-server 200.0.0.1 / 设置域名服务器 配置查看MAC地址表 mac-address-table ? mac-address-table aging-time 100 / 设置超时是时间为100s mac-address-table permanent https://www.doczj.com/doc/5717187644.html, /f0/3 加入永久地址mac-address-table restricted static 0000.0c02.bbcc / f0/6 f0/7 加入静态地址 end show mac-address-table /查看整个Mac地址表 clear mac-address-table restricted static C2950(config-if)# interface fastethernet0/1 /进入接口F0/1子配置模式 interface Ethernet0 /进入以太网口0子配置模式 no shutdown /激活接口 speed ? /查看speed命令的子命令 speed 100 /设置该端口速率为100Mb/s dulplex full/half/auto /设置该端口为全双工 description TO_PC1 /设置该端口描述为TO_PC1 show interface fastethernet 0/1 /查看端口0/1的配置结果 show interface fastethernet 0/1 status /查看端口0/1的状态 配置VTP和STP 一. 配置VTP 2950A #vlan database /进入VLAN配置子模式 show vtp status /查看VTP设置信息 show vlan /查看VLAN配置信息 copy running-config startup-config /保存配置文件 2950A(vlan)#vtp server/client /设置本交换机为server/client模式

(完整版)思科路由器查看配置命令.doc

思科路由器查看配置命令 show run// 看运行状况 show ip route// 看路由表 show int// 看断口 * show ip int br// 看端口 ip 地址 show cdp nei// 察看 cdp 邻居 show ip pro// 察看 ip 协议 查看配置信息用 show 命令,该命令可以在用户模式和特权模式下执行,且在特权模式下看 到的信息比用户模式多。 show 命令很多,常用的有: 1、查看运行配置文件: Router#show running-config 运行配置文件 running-config 位于路由器的 RAM 中,存放的是路由器当前使用的配置信息。 2、查看启动配置文件: Router#show startup-config 启动配置文件 startup-config 位于路由器的 NVRAM 中,可以长期保存。它在启动路由器时装入 RAM ,成为 running-config 。 3、查看路由器的版本信息: Router#show version' 4、查看路由器的接口状态: Router#show ip interface brief 如果接口状态标识为“ Down ”,表示此接口未激活,如果标识为“ Up”,表示此接口已经激活。 5、查看路由表:

Router#show ip route 通过路由表可以看出该路由器已经识别的网络。 6、查看 NAT 翻译情况: Router#show ip nat translation 应该先进行内网与外网的通讯(如:用 ping 命令 ),然后再查看,才能看到翻译情况。

路由器配置命令大全

路由器配置命令大全 视图模式介绍: 普通视图router> 特权视图router# /在普通模式下输入enable 全局视图router(config)# /在特权模式下输入config t 接口视图router(config-if)# /在全局模式下输入int 接口名称例如int s0或int e0 路由协议视图router(config-route)# /在全局模式下输入router 动态路由协议名称 1、基本配置: router>enable /进入特权模式 router#conf t /进入全局配置模式 router(config)# hostname xxx /设置设备名称就好像给我们的计算机起个名字 router(config)#enable password /设置特权口令 router(config)#no ip domain lookup /不允许路由器缺省使用DNS解析命令 router(config)# Service password-encrypt /对所有在路由器上输入的口令进行暗文加密 router(config)#line vty 0 4 /进入设置telnet服务模式 router(config-line)#password xxx /设置telnet的密码 router(config-line)#login /使能可以登陆 router(config)#line con 0 /进入控制口的服务模式 router(config-line)#password xxx /要设置console的密码 router(config-line)#login /使能可以登陆 2、接口配置: router(config)#int s0 /进入接口配置模式serial 0 端口配置(如果是模块化的路由器前面加上槽位编号,例如serial0/0 代表这个路由器的0槽位上的第一个接口) router(config-if)#ip add xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx /添加ip 地址和掩码 router(config-if)#enca hdlc/ppp 捆绑链路协议hdlc 或者ppp 思科缺省串口封装的链路层协议是HDLC所以在show run配置的时候接口上的配置没有,如果要封装为别的链路层协议例如PPP/FR/X25就是看到接口下的enca ppp或者enca fr router(config)#int loopback /建立环回口(逻辑接口)模拟不同的本机网段 router(config-if)#ip add xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx /添加ip 地址和掩码给环回口 在物理接口上配置了ip地址后用no shut启用这个物理接口反之可以用shutdown管理性的关闭接口 3、路由配置: (1)静态路由 router(config)#ip route xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx 下一条或自己的接口 router(config)#ip route 0.0.0.0 0.0.0.0 s 0 添加缺省路由 (2)动态路由 rip协议 router(config)#router rip /启动rip协议 router(config-router)#network xxx.xxx.xxx.xxx /宣告自己的网段 router(config-router)#version 2 转换为rip 2版本 router(config-router)#no auto-summary /关闭自动汇总功能,rip V2才有作用 router(config-router)# passive-int 接口名/启动本路由器的那个接口为被动接口 router(config-router)# nei xxx.xxx.xxx.xxx /广播转单播报文,指定邻居的接ip,

相关主题
文本预览
相关文档 最新文档