当前位置:文档之家 > 关于三层交换机加NAT加动态路由EIGRP实验(修改过的)

关于三层交换机加NAT加动态路由EIGRP实验(修改过的)

关于动态路由EIGRP方面的实验.

要求:1 SWITCHA三层交换机划分两个VLAN分别为VLAN2和VLAN3 VLAN2的网关IP 地址10.10.1.1 VLAN3的网关IP地址10.10.2.1 而SWITCHA三层交换机f0/2端口(IP地址10.15.1.1)与SWITCHB三层交换机f0/1端口(IP地址10.15.1.2)直连互联的

另外SWITCHA三层交换机f0/1端口(IP地址10.17.1.1)与ROUTERA这台路由器的f0/0端口(IP地址10.17.1.2)也是直连的。

2 SWITCHB三层交换机划分两个VLAN分别为VLAN4和VLAN5 VLAN4的网关IP地址10.20.1.1 VLAN5的网关IP地址10.20.2.1 而SWITCHB三层交换机f0/2端口(IP地址10.16.1.1)与SWITCHC三层交换机f0/1端口(IP地址10.16.1.2)直连互联的

3 SWITCHC三层交换机划分两个VLAN分别为VLAN6和VLAN7 VLAN6的网关IP地址10.30.1.1 VLAN7的网关IP地址10.30.2.1

4 总共从ISP运营商申请了五个公网IP地址分别为125.30.220.206---125.30.220.210 子网掩码255.255.255.248 网关125.30.220.210需要做端口复用NAPT进行上网

5 需要用EIGRP动态路由协议可以自动更新网络内的路由表信息

6 三层交换机和路由器必须开启telnet将来好对三层交换机和路由器进行远程管理

7 SWITCHA SWITCHB SWITCHC三台三层交换机的F0/3 F0/4两个端口下都连着二层交换机只不过拓扑图中没有体现。

以上所有的VLAN信息子网掩码全部都是255.255.255.0/24C类子网掩码

具体拓扑图请看

关于三层交换机加NAT加动态路由EIGRP实验(修改过的)

以下为具体的实验命令:

首先需要在SWITCHA这台三层交换机下做如下操作

SWITCHA>enable

SWITCHA#vlan database

SWITCHA(vlan)#vlan 2

SWITCHA(vlan)#vlan 3

SWITCHA(vlan)#exit

SWITCHA#conf t

SWITCHA(config)#interface vlan 2

SWITCHA(config-if)#ip address 10.10.1.1 255.255.255.0

SWITCHA(config-if)#interface vlan 3

SWITCHA(config-if)#ip address 10.10.2.1 255.255.255.0

SWITCHA(config-if)#exit

SWITCHA(config)#ip routing

SWITCHA(config)#end

SWITCHA(config)#interface f0/3

SWITCHA(config-if)#no shutdown

SWITCHA(config-if)#switchport mode trunk

SWITCHA(config-if)#switchport trunk encapsulation dot1q

SWITCHA(config-if)#switchport trunk allowed vlan all

SWITCHA(config)#interface f0/4

SWITCHA(config-if)#no shutdown

SWITCHA(config-if)#switchport mode trunk

SWITCHA(config-if)#switchport trunk encapsulation dot1q

SWITCHA(config-if)#switchport trunk allowed vlan all

SWITCHA(config)#interface f0/2

SWITCHA(config-if)#no switchport(先起为三层接口才能配置ip,trunk不行)

SWITCHA(config-if)#ip address 10.15.1.1 255.255.255.0

SWITCHA(config-if)#no shutdown

SWITCHA(config-if)#exit

SWITCHA(config)#router eigrp 1

SWITCHA(config-router)#network 10.0.0.0 0.0.0.255(一条命令匹配所有接口启用路由)

SWITCHA(config-router)#no auto-summary

SWITCHA(config-router)#exit

SWITCHA(config)#exit

SWITCHA#vlan database

SWITCHA(vlan)#vtp server

SWITCHA(vlan)#vtp domain nt

SWITCHA(vlan)#vtp password 123

SWITCHA(vlan)#exit

SWITCHA#conf t

SWITCHA (config)#line vty 0 4

SWITCHA (config-line)#password 123

SWITCHA (config-line)#login

SWITCHA (config-line)#exit

SWITCHA#copy running-config startup-config

接着需要在SWITCHB这台三层交换机下做如下操作

SWITCHB>enable

SWITCHB#vlan database

SWITCHB(vlan)#vlan 4

SWITCHB(vlan)#vlan 5

SWITCHB(vlan)#exit

SWITCHB#conf t

SWITCHB(config)#interface vlan 4

SWITCHB(config-if)#ip address 10.20.1.1 255.255.255.0 SWITCHB(config-if)#interface vlan 5

SWITCHB(config-if)#ip address 10.20.2.1 255.255.255.0 SWITCHB(config-if)#exit

SWITCHB(config)#ip routing

SWITCHB(config)#end

SWITCHB(config)#interface f0/3

SWITCHB(config-if)#no shutdown

SWITCHB(config-if)#switchport mode trunk

SWITCHB(config-if)#switchport trunk encapsulation dot1q SWITCHB(config-if)#switchport trunk allowed vlan all SWITCHB(config)#interface f0/4

SWITCHB(config-if)#no shutdown

SWITCHB(config-if)#switchport mode trunk

SWITCHB(config-if)#switchport trunk encapsulation dot1q SWITCHB(config-if)#switchport trunk allowed vlan all SWITCHB(config)#interface f0/1

SWITCHB(config-if)#no switchport

SWITCHB(config-if)#ip address 10.15.1.2 255.255.255.0 SWITCHB(config-if)#no shutdown

SWITCHB(config)#interface f0/2

SWITCHB(config-if)#no switchport

SWITCHB(config-if)#ip address 10.16.1.1 255.255.255.0 SWITCHB(config-if)#no shutdown

SWITCHB(config-if)exit

SWITCHB(config)#router eigrp 1

SWITCHB(config-router)#network 10.0.0.0 0.0.0.255 SWITCHB(config-router)#no auto-summary

SWITCHB(config-router)#exit

SWITCHB(config)#exit

SWITCHB#vlan database

SWITCHB(vlan)#vtp server

SWITCHB(vlan)#vtp domain nt

SWITCHB(vlan)#vtp password 123

SWITCHB(vlan)#exit

SWITCHB#conf t

SWITCHB (config)#line vty 0 4

SWITCHB (config-line)#password 123

SWITCHB (config-line)#login

SWITCHB (config-line)#exit

SWITCHB#copy running-config startup-config

接着需要在SWITCHC这台三层交换机下做如下操作

SWITCHC>enable

SWITCHC#vlan database

SWITCHC(vlan)#vlan 6

SWITCHC(vlan)#vlan 7

SWITCHC(vlan)#exit

SWITCHC#conf t

SWITCHC(config)#interface vlan 6

SWITCHC(config-if)#ip address 10.30.1.1 255.255.255.0 SWITCHC(config-if)#interface vlan 7

SWITCHC(config-if)#ip address 10.30.2.1 255.255.255.0 SWITCHC(config-if)#exit

SWITCHC(config)#ip routing

SWITCHC(config)#end

SWITCHC(config)#interface f0/3

SWITCHC(config-if)#no shutdown

SWITCHC(config-if)#switchport mode trunk

SWITCHC(config-if)#switchport trunk encapsulation dot1q SWITCHC(config-if)#switchport trunk allowed vlan all SWITCHC(config)#interface f0/4

SWITCHC(config-if)#no shutdown

SWITCHC(config-if)#switchport mode trunk

SWITCHC(config-if)#switchport trunk encapsulation dot1q SWITCHC(config-if)#switchport trunk allowed vlan all SWITCHC(config)#interface f0/1

SWITCHC(config-if)#no switchport

SWITCHC(config-if)#ip address 10.16.1.2 255.255.255.0 SWITCHC(config-if)#no shutdown

SWITCHB(config-if)exit

SWITCHC(config)#router eigrp 1

SWITCHC(config-router)#network 10.0.0.0 0.0.0.255

SWITCHC(config-router)#no auto-summary

SWITCHC(config-router)#exit

SWITCHC(config)#exit

SWITCHC#vlan database

SWITCHC(vlan)#vtp server

SWITCHC(vlan)#vtp domain nt

SWITCHC(vlan)#vtp password 123

SWITCHC(vlan)#exit

SWITCHC#conf t

SWITCHC(config)#line vty 0 4

SWITCH C(config-line)#password 123

SWITCHC(config-line)#login

SWITCHC(config-line)#exit

SWITCHC#copy running-config startup-config

大概其动态路由EIGRP的就做好了,接着需要做端口复用转换NPAT上网

接着再回到SWITCHA这台三层交换机上做如下操作

SWITCHA>enable

SWITCHA#conf t

SWITCHA(config)#interface f0/1

SWITCHA(config)#no switchport

SWITCHA(config-if)#ip address 10.17.1.1 255.255.255.0

SWITCHA(config-if)#no shutdown

SWITCHA(config-if)#exit

SWITCHA#copy running-config startup-config

接着到ROUTERA这台路由器上做如下操作(假设找ISP申请了五个外网IP地址125.30.220.206---125.30.220.210 子网掩码255.255.255.248 )

ROUTERA>enable

ROUTERA #config t

ROUTERA (config)#interface f0/0

ROUTERA (config-if)#ip address 10.17.1.2 255.255.255.0

ROUTERA (config-if)#ip nat inside

ROUTERA (config-if)#no shut down

ROUTERA (config-if)#exit

ROUTERA (config)#ip routing

ROUTERA (config)#ip route 10.0.0.0 255.0.0.0 10.17.1.1

ROUTERA (config)interface f0/1

ROUTERA (config-if)#ip address 125.30.220.206 255.255.255.248

ROUTERA (config-if)#ip nat outside

ROUTERA (config-if)#no shut down

ROUTERA (config-if)#exit

ROUTERA (config)#ip nat pool nt 125.30.220.206 125.30.220.210 netmask 255.255.255.248

ROUTERA (config)#access-list 1 permit 10.0.0.0 0.255.255.255

用一个防控列表即可

ROUTERA (config)#ip nat inside source list 1 pool nt overload ROUTERA (config)#ip route 0.0.0.0 0.0.0.0 125.30.220.210

ROUTERA (config)#line vty 0 4

ROUTERA (config-line)#password 123

ROUTERA (config-line)#login

ROUTERA (config-line)#exit

ROUTERA (config)#exit

ROUTERA #copy running-config startup-config

最后回到SWITCHA SWITCHB SWITCHC这三台三层交换机做一下操作

SWITCHA(config)#ip route 0.0.0.0 0.0.0.0 10.17.1.2

SWITCHA(config)#exit

SWITCHA#copy running-config startup-config

SWITCHB(config)#ip route 0.0.0.0 0.0.0.0 10.15.1.1(默认路由指向下一跳) SWITCHB(config)#exit

SWITCHB#copy running-config startup-config

SWITCHC(config)#ip route 0.0.0.0 0.0.0.0 10.16.1.1

SWITCHC(config)#exit

SWITCHC#copy running-config startup-config

您好!所有的操作全部都完成了,这些操作都是我自己写的,哪些操作是有误的呢,请给我指正,谢谢!

另外能否再给我解答几个问题

1 如果启动动态路由协议的话RIP EIGRP OSPF这些协议的话如果加上命令参数no auto-summary关闭自动汇总以及不加这个参数开启自动汇总的话那会有什么不同呢??是不是关闭自动汇总了路由器就可以识别无类路由协议携带子网掩码信息,而开启了自动汇总那路由器就可以识别有类路由协议不可以携带子网掩码信息??

不同之处在于如果没有no auto-summary那么在主网边界路由器就不会把更多更细致的路由条目变成更少更粗略的路由条目。

自动汇总和识别无类路由子网掩码没有关系。

自动汇总是路由协议在主网边界把更详细的路由条目变成更粗略的路由条目的过程,距离适量路由协议默认都是开启自动汇总的,但ripv1和igrp不支持手动汇总,因为ripv1和igrp 不是无类路由协议,对于无类距离矢量路由协议来说,虽然默认启动了路由汇总,但可以手工关闭。

2 启动EIGRP协议的时候需要填autonomous自治领域号,请问这个自治领域号一般是怎么得来的呢?还是随意自己定?

这个得看具体情况,处在同一个as号之内的路由器才能共享路由信息,处在同一个as号之内的eigrp和igrp可以自动再发布路由信息,这个as号和bgp中的as号有点类似但不完全一样。只要满足你的管理需要,自己定就可以。

3 动态路由协议中的内部网关协议RIP EIGRP OSPF这些动态路由协议是不是只能宣告直连路由?另外动态路由协议的内部网关协议跟外部网关协议到底有什么不同?我只知道内部网关协议不能穿越自治系统,而外部网关协议可以穿越自治系统,但是能说的更清楚和更通俗些吗?

宣告路由是距离矢量路由协议的特征,链路状态路由协议不通告路由表。Igp是在同一个as中共享路由信息的协议,egp主要是在多个as之间共享路由信息,as一般是由运营商互联,所以as又代表了一个独立的管理区域,比如一个学校,一个园区,一个单位等,egp 就可以把这些不同的管理区域链接起来。而且igp对路由协议要求重点在:复杂链路环境的支持,以及收敛的快速上,而EGP对路由协议的要求重点在:可靠性,可扩展能力,策略上。

以上问题请给我解答!!谢谢您了!!!